chiark / gitweb /
Honour dpkg-architecture's DEB_HOST_GNU_TYPE, to fix cross-building.
[chiark-tcl.git] / debian / rules
index faa763a91b3e1456da41e07357b9a82e80f2e757..f5d4a2af04e6afb48f73af376bb78eb5ff02a622 100755 (executable)
@@ -26,6 +26,15 @@ docdir=usr/share/doc/$(docpackage)
 tclh:=$(firstword $(wildcard /usr/include/tcl8.*/tcl.h))
 tclversion:=$(patsubst /usr/include/tcl%/tcl.h,%,$(tclh))
 
 tclh:=$(firstword $(wildcard /usr/include/tcl8.*/tcl.h))
 tclversion:=$(patsubst /usr/include/tcl%/tcl.h,%,$(tclh))
 
+garch := $(shell dpkg-architecture -q DEB_HOST_GNU_TYPE)
+ifneq ($(garch),)
+
+ifeq ($(origin CC),default)
+export CC=$(garch)-gcc
+endif
+
+endif # $garch
+
 define checkdir
        test -f hbytes/hbytes.tct
 endef
 define checkdir
        test -f hbytes/hbytes.tct
 endef