chiark / gitweb /
Use correct errno value for error writing to new .main during compact.
[chiark-tcl.git] / debian / changelog
index 76235c6d27993241425c9a1b578e012c8c51c69a..a79232e83a9110c218ae7ac4a4b8b85d4168289b 100644 (file)
@@ -2,6 +2,17 @@ chiark-tcl (1.0.2) unstable; urgency=low
 
   Bugfixes:
   * Do not adns_cancel in the middle of adns_forallqueries.
+  * strlen returns size_t, not int; fixed up everywhere relevant.
+    Closes #393970.  (Bug exists only where int and ssize_t differ.)
+  * Use correct errno value for error writing to new .main during compact.
+
+  Portability fixes:
+  * Remove unecessary assertion of val<=0xffffffffUL where uint32_t val;
+    Closes: #394039 (FTBFS due to unhelpful GCC warning).
+
+  Internal improvements:
+  * Add a few assertions about *_LLEN in adns.c.
+  * Comprehensive review of use of `int' and defense against overflow.
 
  --