chiark / gitweb /
fix spelling of defence in changelog
[chiark-tcl.git] / debian / changelog
index 76235c6d27993241425c9a1b578e012c8c51c69a..8f73e7551b729e27f7ece76ed12754d6197344e4 100644 (file)
@@ -2,6 +2,21 @@ chiark-tcl (1.0.2) unstable; urgency=low
 
   Bugfixes:
   * Do not adns_cancel in the middle of adns_forallqueries.
+  * cdb: When cdbwr update writerecord fails, try to recover the
+    situation to sanity so we don't corrupt the log later; if this
+    fails, mark the cdb broken.
+  * strlen returns size_t, not int; fixed up everywhere relevant.
+    Closes #393970.  (Bug exists only where int and ssize_t differ.)
+  * Use correct errno value for error writing to new .main during compact.
+  * Do not coredump if fclose journal fails during compact.
+
+  Portability fixes:
+  * Remove unecessary assertion of val<=0xffffffffUL where uint32_t val;
+    Closes: #394039 (FTBFS due to unhelpful GCC warning).
+
+  Internal improvements:
+  * Add a few assertions about *_LLEN in adns.c.
+  * Comprehensive review of use of `int' and defence against overflow.
 
  --