KDE with Wayland is not working with SysV

Matthew Vernon matthew at debian.org
Thu Jun 22 18:12:17 BST 2023


On 21/06/2023 00:29, Paul Gerdes wrote:

> Now i installed the metapackage "kde-plasma-desktop" and KDE doesnt start.
> After rebooting i land in the SDDM Login-Manager, i choose "Desktop 
> Session: Plasma (Wayland)" and log in into my user account. After a 
> short KDE loading screen i get a black screen. No Windows, No Desktop, 
> No Panel, etc.
> All i can see is the mouse-pointer on my screen and move it on the black 
> screen. And i can switch to another TTY,  thats it.
> I can however choose "Desktop Session: Plasma (X11)" in SDDM and KDE is 
> running fine in X11.
> I also tried installing "kde-plasma-desktop" on the same machine with 
> systemd + wayland and everything ran fine. So the problem has to do with 
> SysV+Wayland and KDE.
> Anyone knows how i can get this to work?

I don't, I'm afraid, and I've never used wayland. Some ideas:
* is there some systemd service that wayland+KDE uses? it might be 
there's a missing init script or equivalent (devuan might have one already)
* what logs are there? presumably something hasn't worked right, and 
you'd like to hope it's objecting in the logs :)
* you might find the KDE folks would be helpful, even if just at saying 
"ah, yes, here's the bit of systemd we use"

Sorry that's not very definitive!



More information about the Debian-init-diversity mailing list