Runit with KDE Plasma: krunner current working directory /

Martin Steigerwald martin at
Tue Feb 14 21:22:56 GMT 2023

Martin Steigerwald - 14.02.23, 22:06:32 CET:
> Then I tried:
> % grep -B 1 Exec= /usr/share/kglobalaccel/org.kde.krunner.desktop
> [Desktop Entry]
> Exec=sh -c "touch /tmp/krunner-desktop; cd /home/USER;
> /usr/bin/krunner" --
> [Desktop Action RunClipboard]
> Exec=sh -c "touch /tmp/krunner-clip; cd /home/USER; /usr/bin/krunner
> -c"
> However konsole started from krunner is still in "/" and I get:
> %  LANG=en ls /tmp/krunner*
> ls: cannot access '/tmp/krunner*': No such file or directory
> So the Exec= line in the desktop file appears to be ignored by
> whatever starts krunner.
> I wonder whether I just restart krunner from my .zshrc or something
> like that or from a file in ~/.config/plasma-workspace/env in case
> that still works.

That did not work either. Not sure whether executable shell script in 
there still get run by Plasma.

However what works is switching the session type to Plasma (Wayland).

Then a konsole started from krunner is in $HOME.

Could it be that with X11 DBUS activation is always used, no matter what 
is in the desktop file?


More information about the Debian-init-diversity mailing list