Runit with KDE Plasma: krunner current working directory /

Martin Steigerwald martin at
Tue Feb 14 21:06:32 GMT 2023

Martin Steigerwald - 14.02.23, 21:48:39 CET:
> > basically respectively use
> > Exec=/usr/bin/krunner
> > and
> > Exec=krunner -c
> > 
> > if it works you can install a diversion on that file
> Now I am seriously confused, cause I do have:
> % grep -B 1 Exec= /usr/share/kglobalaccel/org.kde.krunner.desktop
> [Desktop Entry]
> Exec=/usr/bin/krunner
> --
> [Desktop Action RunClipboard]
> Exec=krunner -c
> The file is in package plasma-workspace 4:5.26.90-1.
> Maybe it works the other way around, i.e. with DBUS activation?
> Actually if I read above commit diff, then it is exactly that.
> -krunner +DBUS activitation if I read the patch correctly.
> Will try.

Does not work. I tried with DBUS activation and a konsole started from 
krunner still was in "/".

% grep -B 1 Exec= /usr/share/kglobalaccel/org.kde.krunner.desktop
[Desktop Entry]
Exec=dbus-send --type=method_call --dest=org.kde.krunner /App 
[Desktop Action RunClipboard]
Exec=dbus-send --type=method_call --dest=org.kde.krunner /App 

Then I tried:

% grep -B 1 Exec= /usr/share/kglobalaccel/org.kde.krunner.desktop
[Desktop Entry]
Exec=sh -c "touch /tmp/krunner-desktop; cd /home/USER; /usr/bin/krunner"
[Desktop Action RunClipboard]
Exec=sh -c "touch /tmp/krunner-clip; cd /home/USER; /usr/bin/krunner -c"

However konsole started from krunner is still in "/" and I get:

%  LANG=en ls /tmp/krunner*
ls: cannot access '/tmp/krunner*': No such file or directory

So the Exec= line in the desktop file appears to be ignored by whatever 
starts krunner.

I wonder whether I just restart krunner from my .zshrc or something like 
that or from a file in ~/.config/plasma-workspace/env in case that still 


More information about the Debian-init-diversity mailing list