chiark / gitweb /
Work around inkscape accessing its environment.
authorSimon Tatham <anakin@pobox.com>
Wed, 27 Oct 2021 17:10:24 +0000 (18:10 +0100)
committerSimon Tatham <anakin@pobox.com>
Wed, 27 Oct 2021 17:47:04 +0000 (18:47 +0100)
Bug #997904 points out that even this command-line use of Inkscape
will try to write to ~/.config/inkscape (in order to create a default
one if it's not already there), and also, will try to initialise GDK
(especially strange in the absence of an X or Wayland server, where it
will try to fall back to the HTTP-server based Broadway backend).

Worked around by resetting $HOME to the build directory, where it
doesn't matter if we create an Inkscape config directory, and by
setting GDK_BACKEND to the empty string, which seems to inhibit it
trying to actually launch any backends.

debian/rules

index f64a235ee75d249b380c7785b7502a55ee0856a2..7df1895db44e9329987ea5a92f648a781a40f77b 100755 (executable)
@@ -8,5 +8,5 @@ override_dh_auto_configure:
 
 override_dh_auto_build-arch:
        dh_auto_build
-       cd resources && ./make-graphics.sh
+       cd resources && env HOME=$$PWD GDK_BACKEND= ./make-graphics.sh
        cd resources && ../debian/make-debian-icons.py