chiark / gitweb /
Revert "debian/: Update for Debhelper 10."
[tripe] / debian / rules
index 9b5065a32ff51befd150d7b5cb74b2f226b00c5c..b45a6be5e7aad9b12cf94edd4fa3bfe1abd83bb6 100755 (executable)
@@ -1,6 +1,6 @@
 #! /usr/bin/make -f
 
-DH_OPTIONS              = -Bdebian/build
+DH_OPTIONS              = --parallel -Bdebian/build
 
 ###--------------------------------------------------------------------------
 ### Configuration.
@@ -9,7 +9,6 @@ OVERRIDES               += auto_configure
 dh_auto_configure_OPTS  = --
 
 ## Various files and directories.
-dh_auto_configure_OPTS += --libdir="\$${prefix}/lib"
 dh_auto_configure_OPTS += --libexecdir="\$${libdir}/tripe"
 dh_auto_configure_OPTS += --with-configdir="/etc/tripe"
 dh_auto_configure_OPTS += --with-socketdir="/var/run"
@@ -62,7 +61,7 @@ dh-install-hook::
 ###--------------------------------------------------------------------------
 ### Some machinery for overriding Debhelper in a structured way.
 
-%:; dh $@ --without autoreconf $(DH_OPTIONS)
+%:; dh $@ $(DH_OPTIONS)
 
 $(foreach o, $(sort $(OVERRIDES)), dh-$o-hook)::; @:
 $(foreach o, $(sort $(OVERRIDES)), override_dh_$o): override_dh_%: dh-%-hook