chiark
/
gitweb
/
~mdw
/
runlisp
/ blobdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
|
commitdiff
|
tree
raw
|
inline
| side by side
Generally bring up-to-date.
[runlisp]
/
debian
/
rules
diff --git
a/debian/rules
b/debian/rules
index 99b8a032b88b7878dd8e1a31785aab7eca1a6b18..47eb20d2bec872fb4469676ca48e0fa440dd049e 100755
(executable)
--- a/
debian/rules
+++ b/
debian/rules
@@
-1,5
+1,7
@@
#! /usr/bin/make -f
#! /usr/bin/make -f
+export DH_COMPAT = 4
+
build:
rm -rf build deb-build
mkdir deb-build
build:
rm -rf build deb-build
mkdir deb-build
@@
-7,9
+9,13
@@
build:
make -C deb-build
touch build
make -C deb-build
touch build
+clean:
+ dh_clean
+ rm -rf deb-build build
+
install: build
dh_clean
install: build
dh_clean
- make -C deb-build install DESTDIR=`pwd`/debian/
tmp
+ make -C deb-build install DESTDIR=`pwd`/debian/
cfd
binary-indep: install
dh_testdir -i
binary-indep: install
dh_testdir -i
@@
-29,7
+35,7
@@
binary: binary-indep binary-arch
source:
rm -rf deb-build/*.tar.gz deb-build/=deb=
source:
rm -rf deb-build/*.tar.gz deb-build/=deb=
- make -C deb-build dist
+ make -C deb-build dist
PACKAGE=cfd
mkdir deb-build/=deb=
cd deb-build/=deb=; tar xvfz ../*.tar.gz
d=`pwd`; cd ..; dpkg-source -i -b $$d/deb-build/=deb=/*
mkdir deb-build/=deb=
cd deb-build/=deb=; tar xvfz ../*.tar.gz
d=`pwd`; cd ..; dpkg-source -i -b $$d/deb-build/=deb=/*