chiark / gitweb /
gremlin/: Start on making it be a proper built thing.
[autoys] / debian / control
index c1edd5ec1af33c3b1ed4df113614e72993ec5caa..9181280f80fb1ffb30ba965049ce8f41a3bd7ebc 100644 (file)
@@ -8,4 +8,34 @@ Standards-Version: 3.1.1
 Package: autoys
 Architecture: all
 Section: sound
+Depends:
+       gremlin
 Description: A convenience package which depends on the other `autoys' packages.
+
+Package: gremlin
+Architecture: all
+Section: sound
+Depends: ${python:Depends}, 
+       python-pyparsing,
+       python-gst0.10, python-gobject-2,
+       python-eyed3, python-imaging
+Description: Maintain converted trees of audio files.
+ The `gremlin' program converts audio files in an input `master' directory
+ tree, which presumably contains high-quality (ideally lossless) encodings of
+ interesting audio, writing corresponding converted files to a collection of
+ output directory trees.  It's non-interactive, idempotent, and restartable;
+ it never modifies its master tree.  It's exactly the sort of thing you want
+ to install as a daily cron job.
+ .
+ The gremlin reads a configuration file which describes the conversion policy
+ for each of the output trees.  The policy can say things like: copy MP3
+ files up to 160kb/s, or Ogg Vorbis files up to 128kb/s; and convert
+ everything else to 128kb/s Ogg Vorbis.
+ .
+ The gremlin can also convert image files, such as cover art.
+ .
+ Input files can be anything which GStreamer and/or the Python Imaging
+ Library can understand; output files are more constrained, because the
+ gremlin has to be able to understand their relevant properties.  The
+ currently supported audio formats are Ogg Vorbis and MP3; image formats are
+ JPEG, PNG, and BMP.