chiark / gitweb /
*** empty log message ***
[sympathy.git] / src / Makefile.am
index 94f0f7b2b45eb69d2645ea551fa340b94eb20163..d162ccd2c7936da9b511161dd89dec682ca90fde 100644 (file)
@@ -8,6 +8,30 @@
 # $Id$
 #
 # $Log$
+# Revision 1.15  2008/02/15 16:48:56  james
+# *** empty log message ***
+#
+# Revision 1.14  2008/02/15 03:32:07  james
+# *** empty log message ***
+#
+# Revision 1.13  2008/02/14 16:21:17  james
+# *** empty log message ***
+#
+# Revision 1.12  2008/02/14 02:46:44  james
+# *** empty log message ***
+#
+# Revision 1.11  2008/02/14 01:55:57  james
+# *** empty log message ***
+#
+# Revision 1.10  2008/02/13 18:05:06  james
+# *** empty log message ***
+#
+# Revision 1.9  2008/02/13 16:57:29  james
+# *** empty log message ***
+#
+# Revision 1.8  2008/02/13 09:12:20  james
+# *** empty log message ***
+#
 # Revision 1.7  2008/02/12 22:36:46  james
 # *** empty log message ***
 #
 
 INCLUDES=
 
-HDRS=ansi.h context.h crt.h history.h keys.h project.h prototypes.h \
-       ring.h sympathy.h tty.h vt102.h
+# NB order here matters.
+PROJECTHDRS= crt.h tty.h ansi.h vt102.h keys.h history.h ring.h slide.h \
+               log.h ipc.h symsocket.h keydis.h cmd.h lockfile.h context.h \
+               prototypes.h
+
+HDRS=project.h 
 
 SRCS=ansi.c crt.c html.c libsympathy.c render.c  version.c vt102.c tty.c \
-       history.c ring.c ptty.c
+       keydis.c history.c ring.c ptty.c terminal.c util.c log.c ipc.c \
+       slide.c symsocket.c  serial.c cmd.c lockfile.c
 
 CPROTO=cproto
 
@@ -53,14 +82,14 @@ libsympathy_la_SOURCES = ${SYMPATHYSRCS}
 
 libsympathy_a_CFLAGS = ${AM_CFLAGS}
 
-BUILT_SOURCES = version.h
+BUILT_SOURCES = version.h sympathy.h
 
 lib_LIBRARIES=libsympathy.a
 lib_LTLIBRARIES=libsympathy.la
 
 include_HEADERS=sympathy.h
 
-AM_CFLAGS=-g
+AM_CFLAGS=-g -Werror
 
 libsympathy_la_LDFLAGS = \
         -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
@@ -76,12 +105,15 @@ VDEF=${shell echo `cat ${VFD}/version-major`.`cat ${VFD}/version-minor`.`cat ${V
 
 protos:
        echo > prototypes.h
-       ${CPROTO} -v ${INCLUDES} ${SRCS} > prototypes.tmp
+       ${CPROTO} -e -v ${INCLUDES} ${SRCS} > prototypes.tmp
        mv -f prototypes.tmp prototypes.h
 
 tidy: ${SRCS} ${HDRS}
        indent -i2 -ts0 ${SRCS} ${HDRS} 
 
+sympathy.h: ${PROJECTHDRS} sympathy.h.head sympathy.h.tail
+       cat sympathy.h.head ${PROJECTHDRS} sympathy.h.tail > $@ || /bin/rm -f $@
+
 version.h: $(VFD)/version-files $(VFD)/version-major \
        $(VFD)/version-minor $(VFD)/version-micro \
        $(VFD)/version-md5sums ${VFS} Makefile