chiark / gitweb /
serialmgr: Copy from woking.cam.xci-test.com
[sympathy.git] / src / Makefile.am
index ad3e0ada9239b9fe364d4163954cd772b6c97ee9..995cffbd189b1eaf5d2e78f687bef927b82e6d29 100644 (file)
@@ -2,12 +2,36 @@
 #
 # Makefile.am:
 #
-# Copyright (c) 2008 James McKenzie <james@fishsoup.dhs.org>,
+# Copyright (c) 2008 James McKenzie <sympathy@madingley.org>,
 # All rights reserved.
 #
-# $Id$
+# $Id: Makefile.am,v 1.24 2008/03/07 13:16:02 james Exp $
+#
+# $Log: Makefile.am,v $
+# Revision 1.24  2008/03/07 13:16:02  james
+# *** empty log message ***
+#
+# Revision 1.23  2008/03/06 16:49:05  james
+# *** empty log message ***
+#
+# Revision 1.22  2008/03/03 06:04:18  james
+# *** empty log message ***
+#
+# Revision 1.21  2008/02/28 22:55:27  staffcvs
+# *** empty log message ***
+#
+# Revision 1.20  2008/02/27 15:04:32  james
+# *** empty log message ***
+#
+# Revision 1.19  2008/02/27 10:47:34  james
+# *** empty log message ***
+#
+# Revision 1.18  2008/02/26 23:23:17  james
+# *** empty log message ***
+#
+# Revision 1.17  2008/02/24 00:42:53  james
+# *** empty log message ***
 #
-# $Log$
 # Revision 1.16  2008/02/22 23:39:27  james
 # *** empty log message ***
 #
@@ -64,14 +88,16 @@ INCLUDES=
 
 # NB order here matters.
 PROJECTHDRS= crt.h utf8.h tty.h ansi.h vt102.h keys.h history.h ring.h slide.h \
-               log.h ipc.h symsocket.h keydis.h cmd.h lockfile.h context.h \
-               prototypes.h
+               log.h ipc.h symsocket.h keydis.h cmd.h lockfile.h rx.h \
+               context.h vt102_charset.h prototypes.h
+
+HDRS=project.h  ${PROJECTHDRS}
 
-HDRS=project.h 
 
 SRCS=ansi.c crt.c html.c libsympathy.c render.c  version.c vt102.c tty.c \
        keydis.c history.c ring.c ptty.c terminal.c util.c log.c ipc.c \
-       slide.c symsocket.c  serial.c cmd.c lockfile.c utf8.c
+       slide.c symsocket.c  serial.c cmd.c lockfile.c utf8.c vt102_charset.c \
+       rotate.c raw.c
 
 CPROTO=cproto
 
@@ -79,6 +105,10 @@ SYMPATHYSRCS=${SRCS}
 
 noinst_HEADERS= prototypes.h ${HDRS}
 
+EXTRA_DIST=sympathy.h.tail
+
+clean-local:
+       -rm -f sympathy.h version.h version-num
 
 libsympathy_a_SOURCES =  ${SYMPATHYSRCS}
 libsympathy_la_SOURCES = ${SYMPATHYSRCS}
@@ -106,20 +136,21 @@ VCHK=${shell cat ${VFS} | @MD5SUM@ | @AWK@ '{print $$1 }' }
 VNUM=${shell @GREP@ ${VCHK} ${VFD}/version-md5sums | @AWK@ '{ print $$2 }'  }
 VDEF=${shell echo `cat ${VFD}/version-major`.`cat ${VFD}/version-minor`.`cat ${VFD}/version-micro` }
 
-protos:
+protos: sympathy.h
        echo > prototypes.h
        ${CPROTO} -e -v ${INCLUDES} ${SRCS} > prototypes.tmp
        mv -f prototypes.tmp prototypes.h
 
 tidy: ${SRCS} ${HDRS}
        indent -i2 -ts0 ${SRCS} ${HDRS} 
+       /bin/rm -f *~
 
 sympathy.h: ${PROJECTHDRS} sympathy.h.head sympathy.h.tail
        cat sympathy.h.head ${PROJECTHDRS} sympathy.h.tail > $@ || /bin/rm -f $@
 
 version.h: $(VFD)/version-files $(VFD)/version-major \
        $(VFD)/version-minor $(VFD)/version-micro \
-       $(VFD)/version-md5sums ${VFS} Makefile
+       $(VFD)/version-md5sums ${VFS} 
        if [ .${VNUM} = . ]; then \
                echo "#define VERSION \"libsympathy Version ${VDEF} + Edits\"" > version.h; \
                echo ${VDEF}-E > version-num; \