chiark / gitweb /
*** empty log message ***
[sympathy.git] / src / Makefile.am
index 6cfd2216f2a4745eef115cb1a8d195772a638f20..94f0f7b2b45eb69d2645ea551fa340b94eb20163 100644 (file)
@@ -8,6 +8,15 @@
 # $Id$
 #
 # $Log$
+# Revision 1.7  2008/02/12 22:36:46  james
+# *** empty log message ***
+#
+# Revision 1.6  2008/02/09 15:47:28  james
+# *** empty log message ***
+#
+# Revision 1.5  2008/02/08 15:06:42  james
+# *** empty log message ***
+#
 # Revision 1.4  2008/02/07 01:04:16  james
 # *** empty log message ***
 #
 #
 #
 
-INCLUDES = 
+INCLUDES=
+
+HDRS=ansi.h context.h crt.h history.h keys.h project.h prototypes.h \
+       ring.h sympathy.h tty.h vt102.h
+
+SRCS=ansi.c crt.c html.c libsympathy.c render.c  version.c vt102.c tty.c \
+       history.c ring.c ptty.c
 
-SRCS= ansi.c crt.c html.c libsympathy.c render.c  version.c vt102.c tty.c
 CPROTO=cproto
 
 SYMPATHYSRCS=${SRCS}
 
-noinst_HEADERS= project.h prototypes.h
+noinst_HEADERS= prototypes.h ${HDRS}
 
 
 libsympathy_a_SOURCES =  ${SYMPATHYSRCS}
@@ -65,6 +79,9 @@ protos:
        ${CPROTO} -v ${INCLUDES} ${SRCS} > prototypes.tmp
        mv -f prototypes.tmp prototypes.h
 
+tidy: ${SRCS} ${HDRS}
+       indent -i2 -ts0 ${SRCS} ${HDRS} 
+
 version.h: $(VFD)/version-files $(VFD)/version-major \
        $(VFD)/version-minor $(VFD)/version-micro \
        $(VFD)/version-md5sums ${VFS} Makefile