chiark / gitweb /
*** empty log message ***
[sympathy.git] / src / Makefile.am
index d162ccd2c7936da9b511161dd89dec682ca90fde..6980119532a479e6fa01af4bdbc097f7622669c8 100644 (file)
@@ -8,6 +8,24 @@
 # $Id$
 #
 # $Log$
+# Revision 1.21  2008/02/28 22:55:27  staffcvs
+# *** empty log message ***
+#
+# Revision 1.20  2008/02/27 15:04:32  james
+# *** empty log message ***
+#
+# Revision 1.19  2008/02/27 10:47:34  james
+# *** empty log message ***
+#
+# Revision 1.18  2008/02/26 23:23:17  james
+# *** empty log message ***
+#
+# Revision 1.17  2008/02/24 00:42:53  james
+# *** empty log message ***
+#
+# Revision 1.16  2008/02/22 23:39:27  james
+# *** empty log message ***
+#
 # Revision 1.15  2008/02/15 16:48:56  james
 # *** empty log message ***
 #
 INCLUDES=
 
 # NB order here matters.
-PROJECTHDRS= crt.h tty.h ansi.h vt102.h keys.h history.h ring.h slide.h \
+PROJECTHDRS= crt.h utf8.h tty.h ansi.h vt102.h keys.h history.h ring.h slide.h \
                log.h ipc.h symsocket.h keydis.h cmd.h lockfile.h context.h \
-               prototypes.h
+               vt102_charset.h prototypes.h
+
+HDRS=project.h  ${PROJECTHDRS}
 
-HDRS=project.h 
 
 SRCS=ansi.c crt.c html.c libsympathy.c render.c  version.c vt102.c tty.c \
        keydis.c history.c ring.c ptty.c terminal.c util.c log.c ipc.c \
-       slide.c symsocket.c  serial.c cmd.c lockfile.c
+       slide.c symsocket.c  serial.c cmd.c lockfile.c utf8.c vt102_charset.c
 
 CPROTO=cproto
 
@@ -76,6 +95,10 @@ SYMPATHYSRCS=${SRCS}
 
 noinst_HEADERS= prototypes.h ${HDRS}
 
+EXTRA_DIST=sympathy.h.tail
+
+clean-local:
+       -rm -f sympathy.h version.h version-num
 
 libsympathy_a_SOURCES =  ${SYMPATHYSRCS}
 libsympathy_la_SOURCES = ${SYMPATHYSRCS}
@@ -110,13 +133,14 @@ protos:
 
 tidy: ${SRCS} ${HDRS}
        indent -i2 -ts0 ${SRCS} ${HDRS} 
+       /bin/rm -f *~
 
 sympathy.h: ${PROJECTHDRS} sympathy.h.head sympathy.h.tail
        cat sympathy.h.head ${PROJECTHDRS} sympathy.h.tail > $@ || /bin/rm -f $@
 
 version.h: $(VFD)/version-files $(VFD)/version-major \
        $(VFD)/version-minor $(VFD)/version-micro \
-       $(VFD)/version-md5sums ${VFS} Makefile
+       $(VFD)/version-md5sums ${VFS} 
        if [ .${VNUM} = . ]; then \
                echo "#define VERSION \"libsympathy Version ${VDEF} + Edits\"" > version.h; \
                echo ${VDEF}-E > version-num; \