chiark / gitweb /
*** empty log message ***
[sympathy.git] / src / Makefile.am
index 6cfd2216f2a4745eef115cb1a8d195772a638f20..6980119532a479e6fa01af4bdbc097f7622669c8 100644 (file)
@@ -8,6 +8,57 @@
 # $Id$
 #
 # $Log$
+# Revision 1.21  2008/02/28 22:55:27  staffcvs
+# *** empty log message ***
+#
+# Revision 1.20  2008/02/27 15:04:32  james
+# *** empty log message ***
+#
+# Revision 1.19  2008/02/27 10:47:34  james
+# *** empty log message ***
+#
+# Revision 1.18  2008/02/26 23:23:17  james
+# *** empty log message ***
+#
+# Revision 1.17  2008/02/24 00:42:53  james
+# *** empty log message ***
+#
+# Revision 1.16  2008/02/22 23:39:27  james
+# *** empty log message ***
+#
+# Revision 1.15  2008/02/15 16:48:56  james
+# *** empty log message ***
+#
+# Revision 1.14  2008/02/15 03:32:07  james
+# *** empty log message ***
+#
+# Revision 1.13  2008/02/14 16:21:17  james
+# *** empty log message ***
+#
+# Revision 1.12  2008/02/14 02:46:44  james
+# *** empty log message ***
+#
+# Revision 1.11  2008/02/14 01:55:57  james
+# *** empty log message ***
+#
+# Revision 1.10  2008/02/13 18:05:06  james
+# *** empty log message ***
+#
+# Revision 1.9  2008/02/13 16:57:29  james
+# *** empty log message ***
+#
+# Revision 1.8  2008/02/13 09:12:20  james
+# *** empty log message ***
+#
+# Revision 1.7  2008/02/12 22:36:46  james
+# *** empty log message ***
+#
+# Revision 1.6  2008/02/09 15:47:28  james
+# *** empty log message ***
+#
+# Revision 1.5  2008/02/08 15:06:42  james
+# *** empty log message ***
+#
 # Revision 1.4  2008/02/07 01:04:16  james
 # *** empty log message ***
 #
 #
 #
 
-INCLUDES = 
+INCLUDES=
+
+# NB order here matters.
+PROJECTHDRS= crt.h utf8.h tty.h ansi.h vt102.h keys.h history.h ring.h slide.h \
+               log.h ipc.h symsocket.h keydis.h cmd.h lockfile.h context.h \
+               vt102_charset.h prototypes.h
+
+HDRS=project.h  ${PROJECTHDRS}
+
+
+SRCS=ansi.c crt.c html.c libsympathy.c render.c  version.c vt102.c tty.c \
+       keydis.c history.c ring.c ptty.c terminal.c util.c log.c ipc.c \
+       slide.c symsocket.c  serial.c cmd.c lockfile.c utf8.c vt102_charset.c
 
-SRCS= ansi.c crt.c html.c libsympathy.c render.c  version.c vt102.c tty.c
 CPROTO=cproto
 
 SYMPATHYSRCS=${SRCS}
 
-noinst_HEADERS= project.h prototypes.h
+noinst_HEADERS= prototypes.h ${HDRS}
+
+EXTRA_DIST=sympathy.h.tail
 
+clean-local:
+       -rm -f sympathy.h version.h version-num
 
 libsympathy_a_SOURCES =  ${SYMPATHYSRCS}
 libsympathy_la_SOURCES = ${SYMPATHYSRCS}
 
 libsympathy_a_CFLAGS = ${AM_CFLAGS}
 
-BUILT_SOURCES = version.h
+BUILT_SOURCES = version.h sympathy.h
 
 lib_LIBRARIES=libsympathy.a
 lib_LTLIBRARIES=libsympathy.la
 
 include_HEADERS=sympathy.h
 
-AM_CFLAGS=-g
+AM_CFLAGS=-g -Werror
 
 libsympathy_la_LDFLAGS = \
         -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
@@ -62,12 +128,19 @@ VDEF=${shell echo `cat ${VFD}/version-major`.`cat ${VFD}/version-minor`.`cat ${V
 
 protos:
        echo > prototypes.h
-       ${CPROTO} -v ${INCLUDES} ${SRCS} > prototypes.tmp
+       ${CPROTO} -e -v ${INCLUDES} ${SRCS} > prototypes.tmp
        mv -f prototypes.tmp prototypes.h
 
+tidy: ${SRCS} ${HDRS}
+       indent -i2 -ts0 ${SRCS} ${HDRS} 
+       /bin/rm -f *~
+
+sympathy.h: ${PROJECTHDRS} sympathy.h.head sympathy.h.tail
+       cat sympathy.h.head ${PROJECTHDRS} sympathy.h.tail > $@ || /bin/rm -f $@
+
 version.h: $(VFD)/version-files $(VFD)/version-major \
        $(VFD)/version-minor $(VFD)/version-micro \
-       $(VFD)/version-md5sums ${VFS} Makefile
+       $(VFD)/version-md5sums ${VFS} 
        if [ .${VNUM} = . ]; then \
                echo "#define VERSION \"libsympathy Version ${VDEF} + Edits\"" > version.h; \
                echo ${VDEF}-E > version-num; \