chiark / gitweb /
*** empty log message ***
[sympathy.git] / src / Makefile.am
index 3793b26f66afd16878a3890ad9fa4a9a552ff038..6980119532a479e6fa01af4bdbc097f7622669c8 100644 (file)
@@ -8,6 +8,15 @@
 # $Id$
 #
 # $Log$
+# Revision 1.21  2008/02/28 22:55:27  staffcvs
+# *** empty log message ***
+#
+# Revision 1.20  2008/02/27 15:04:32  james
+# *** empty log message ***
+#
+# Revision 1.19  2008/02/27 10:47:34  james
+# *** empty log message ***
+#
 # Revision 1.18  2008/02/26 23:23:17  james
 # *** empty log message ***
 #
@@ -73,7 +82,8 @@ PROJECTHDRS= crt.h utf8.h tty.h ansi.h vt102.h keys.h history.h ring.h slide.h \
                log.h ipc.h symsocket.h keydis.h cmd.h lockfile.h context.h \
                vt102_charset.h prototypes.h
 
-HDRS=project.h 
+HDRS=project.h  ${PROJECTHDRS}
+
 
 SRCS=ansi.c crt.c html.c libsympathy.c render.c  version.c vt102.c tty.c \
        keydis.c history.c ring.c ptty.c terminal.c util.c log.c ipc.c \
@@ -85,6 +95,10 @@ SYMPATHYSRCS=${SRCS}
 
 noinst_HEADERS= prototypes.h ${HDRS}
 
+EXTRA_DIST=sympathy.h.tail
+
+clean-local:
+       -rm -f sympathy.h version.h version-num
 
 libsympathy_a_SOURCES =  ${SYMPATHYSRCS}
 libsympathy_la_SOURCES = ${SYMPATHYSRCS}
@@ -126,7 +140,7 @@ sympathy.h: ${PROJECTHDRS} sympathy.h.head sympathy.h.tail
 
 version.h: $(VFD)/version-files $(VFD)/version-major \
        $(VFD)/version-minor $(VFD)/version-micro \
-       $(VFD)/version-md5sums ${VFS} Makefile
+       $(VFD)/version-md5sums ${VFS} 
        if [ .${VNUM} = . ]; then \
                echo "#define VERSION \"libsympathy Version ${VDEF} + Edits\"" > version.h; \
                echo ${VDEF}-E > version-num; \