chiark / gitweb /
*** empty log message ***
[sympathy.git] / src / Makefile.am
index 59bd862bcc69554cca3fe2537ce256ec5962a52f..63a00b4dea6f0c26b79a34b94af1f18e3764cf73 100644 (file)
@@ -8,6 +8,21 @@
 # $Id$
 #
 # $Log$
+# Revision 1.10  2008/02/13 18:05:06  james
+# *** empty log message ***
+#
+# Revision 1.9  2008/02/13 16:57:29  james
+# *** empty log message ***
+#
+# Revision 1.8  2008/02/13 09:12:20  james
+# *** empty log message ***
+#
+# Revision 1.7  2008/02/12 22:36:46  james
+# *** empty log message ***
+#
+# Revision 1.6  2008/02/09 15:47:28  james
+# *** empty log message ***
+#
 # Revision 1.5  2008/02/08 15:06:42  james
 # *** empty log message ***
 #
 #
 #
 
-INCLUDES = 
+INCLUDES=
+
+PROJECTHDRS= crt.h tty.h ansi.h vt102.h keys.h history.h ring.h slide.h log.h ipc.h context.h symsocket.h prototypes.h
+
+HDRS=project.h 
+
+SRCS=ansi.c crt.c html.c libsympathy.c render.c  version.c vt102.c tty.c \
+       history.c ring.c ptty.c terminal.c util.c log.c ipc.c slide.c symsocket.c
 
-SRCS= ansi.c crt.c html.c libsympathy.c render.c  version.c vt102.c tty.c \
-       history.c buf.c
 CPROTO=cproto
 
 SYMPATHYSRCS=${SRCS}
 
-noinst_HEADERS= project.h prototypes.h
+noinst_HEADERS= prototypes.h ${HDRS}
 
 
 libsympathy_a_SOURCES =  ${SYMPATHYSRCS}
@@ -43,14 +63,14 @@ libsympathy_la_SOURCES = ${SYMPATHYSRCS}
 
 libsympathy_a_CFLAGS = ${AM_CFLAGS}
 
-BUILT_SOURCES = version.h
+BUILT_SOURCES = version.h sympathy.h
 
 lib_LIBRARIES=libsympathy.a
 lib_LTLIBRARIES=libsympathy.la
 
 include_HEADERS=sympathy.h
 
-AM_CFLAGS=-g
+AM_CFLAGS=-g -Werror
 
 libsympathy_la_LDFLAGS = \
         -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
@@ -66,9 +86,15 @@ VDEF=${shell echo `cat ${VFD}/version-major`.`cat ${VFD}/version-minor`.`cat ${V
 
 protos:
        echo > prototypes.h
-       ${CPROTO} -v ${INCLUDES} ${SRCS} > prototypes.tmp
+       ${CPROTO} -e -v ${INCLUDES} ${SRCS} > prototypes.tmp
        mv -f prototypes.tmp prototypes.h
 
+tidy: ${SRCS} ${HDRS}
+       indent -i2 -ts0 ${SRCS} ${HDRS} 
+
+sympathy.h: ${PROJECTHDRS} sympathy.h.head sympathy.h.tail
+       cat sympathy.h.head ${PROJECTHDRS} sympathy.h.tail > $@ || /bin/rm -f $@
+
 version.h: $(VFD)/version-files $(VFD)/version-major \
        $(VFD)/version-minor $(VFD)/version-micro \
        $(VFD)/version-md5sums ${VFS} Makefile