chiark / gitweb /
udevadm: info - fix --query=all for devices without a device node
[elogind.git] / udev / Makefile.am
index 62739c05d99bd50c3cb51a9d0525ec3587fe6508..b9e2e89620b2da468625d5a70aef3dacd4dedc5a 100644 (file)
@@ -1,3 +1,5 @@
+include $(top_srcdir)/Makefile.am.inc
+
 SUBDIRS = \
        lib
 
@@ -8,11 +10,6 @@ sbin_PROGRAMS = \
 noinst_PROGRAMS = \
        test-udev
 
-AM_CPPFLAGS = \
-       -DSYSCONFDIR=\""$(sysconfdir)"\" \
-       -DUDEV_PREFIX=\""$(udev_prefix)"\" \
-       -D_LIBUDEV_COMPILATION
-
 common_ldadd =
 
 common_files = \
@@ -28,13 +25,17 @@ common_files = \
        udev_sysfs.c \
        udev_utils.c \
        udev_utils_file.c \
-       lib/list.h \
+       udev_selinux.c \
+       list.h \
        lib/libudev.h \
        lib/libudev-private.h \
        lib/libudev.c \
+       lib/libudev-list.c \
+       lib/libudev-util.c \
        lib/libudev-device.c \
        lib/libudev-monitor.c \
-       lib/libudev-util.c \
+       lib/libudev-enumerate.c \
+       lib/libudev-queue.c \
        lib/libudev-ctrl.c
 
 if USE_SELINUX