chiark / gitweb /
build-sys: really override CFLAGS for gtk-doc
[elogind.git] / docs / libudev / Makefile.am
index 9eb5c5cbf6a5b19b14bfe98a735e311542b9608d..13e448ace0a28bbe1eb6e69c28f2a4ce125be4a1 100644 (file)
@@ -72,6 +72,14 @@ content_files = version.xml
 # e.g. expand_content_files=running.sgml
 expand_content_files=
 
+# Hack, hack. You silly gtk-doc, you must not add  CFLAGS multiple
+# times when calling gcc; it surely can not work with options that must
+# be listed only once.
+# Kill CFLAGS here because gtk-doc thinks adding CFLAGS to CC _and_ also
+# adding CFLAGS itself again would work.
+override CFLAGS=
+override LDFLAGS=
+
 # CFLAGS and LDFLAGS for compiling gtkdoc-scangobj with your library.
 # Only needed if you are using gtkdoc-scangobj to dynamically query widget
 # signals and properties.
@@ -81,7 +89,7 @@ GTKDOC_CFLAGS=
 GTKDOC_LIBS=
 
 # This includes the standard gtk-doc make rules, copied by gtkdocize.
-include $(top_srcdir)/gtk-doc.make
+include $(top_srcdir)/docs/gtk-doc.make
 
 # Other files to distribute
 # e.g. EXTRA_DIST += version.xml.in
@@ -94,6 +102,6 @@ EXTRA_DIST += version.xml.in
 
 # Comment this out if you want your docs-status tested during 'make check'
 if ENABLE_GTK_DOC
-#TESTS_ENVIRONMENT = cd $(srcsrc)
-#TESTS = $(GTKDOC_CHECK)
+TESTS_ENVIRONMENT = cd $(top_srcdir)
+TESTS = $(GTKDOC_CHECK)
 endif