chiark / gitweb /
update TODO
[elogind.git] / docs / gudev / Makefile.am
index f2e953247a102a4e2cfc9fc80f0696fed91017cd..586dd8d190e5b954b65070fcd1ba36a41cc50d18 100644 (file)
@@ -21,7 +21,7 @@ DOC_MAIN_SGML_FILE=$(DOC_MODULE)-docs.xml
 # gtk-doc will search all .c & .h files beneath here for inline comments
 # documenting the functions and macros.
 # e.g. DOC_SOURCE_DIR=../../../gtk
-DOC_SOURCE_DIR=$(top_srcdir)/src/gudev
+DOC_SOURCE_DIR=$(top_srcdir)/src/gudev $(top_builddir)/src/gudev
 
 # Extra options to pass to gtkdoc-scangobj. Not normally needed.
 SCANGOBJ_OPTIONS=
@@ -57,7 +57,7 @@ EXTRA_HFILES=
 
 # Header files to ignore when scanning. Use base file name, no paths
 # e.g. IGNORE_HFILES=gtkdebug.h gtkintl.h
-IGNORE_HFILES=
+IGNORE_HFILES=gudevenumtypes.h gudevmarshal.h
 
 # Images to copy into HTML directory.
 # e.g. HTML_IMAGES=$(top_srcdir)/gtk/stock-icons/stock_about_24.png
@@ -83,11 +83,11 @@ GTKDOC_CFLAGS = \
        -I$(top_builddir)/src/gudev
 
 GTKDOC_LIBS = \
-        $(GLIB_LIBS) \
-        $(top_builddir)/libgudev-1.0.la
+       $(GLIB_LIBS) \
+       $(top_builddir)/libgudev-1.0.la
 
 # This includes the standard gtk-doc make rules, copied by gtkdocize.
-include $(top_srcdir)/gtk-doc.make
+include $(top_srcdir)/docs/gtk-doc.make
 
 # Other files to distribute
 # e.g. EXTRA_DIST += version.xml.in
@@ -100,6 +100,6 @@ EXTRA_DIST += version.xml.in
 
 # Comment this out if you want your docs-status tested during 'make check'
 if ENABLE_GTK_DOC
-#TESTS_ENVIRONMENT = cd $(srcsrc)
-#TESTS = $(GTKDOC_CHECK)
+TESTS_ENVIRONMENT = cd $(top_srcdir)
+TESTS = $(GTKDOC_CHECK)
 endif