chiark / gitweb /
[PATCH] get 'make release' to work properly again.
[elogind.git] / udev.spec
1 Summary: A userspace implementation of devfs
2 Name: udev
3 Version: 004_bk
4 Release: 1
5 License: GPL
6 Group: Utilities/System
7 Source: ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/%{name}-%{version}.tar.gz
8 ExclusiveOS: Linux
9 Vendor: Greg Kroah-Hartman <greg@kroah.com>
10 BuildRoot: /var/tmp/%{name}-%{version}-%{release}-root
11 Prereq: /bin/sh, fileutils, hotplug
12
13 %description
14 udev is a implementation of devfs in userspace using sysfs and
15 /sbin/hotplug. It requires a 2.6 kernel to run properly.
16
17 %prep
18 %setup -q
19
20 %build
21 make CC="gcc $RPM_OPT_FLAGS"
22
23 %install
24 make prefix=$RPM_BUILD_ROOT install
25 rm -f ${RPM_BUILD_ROOT}/etc/hotplug.d/default/udev.hotplug
26 ln -s /sbin/udev ${RPM_BUILD_ROOT}/etc/hotplug.d/default/udev.hotplug
27
28 %clean
29 rm -rf $RPM_BUILD_ROOT
30
31 %files
32 %defattr(0644,root,root)
33 %doc COPYING README TODO ChangeLog
34 %attr(755,root,root) /sbin/udev
35 %attr(755,root,root) /udev/
36 %attr(755,root,root) /etc/udev/
37 %attr(0644,root,root) /etc/udev/udev.config
38 %attr(0644,root,root) /etc/udev/udev.permissions
39 %attr(-,root,root) /etc/hotplug.d/default/udev.hotplug
40 %attr(0644,root,root) %{_mandir}/man8/udev.8*
41
42 %changelog
43 * Fri Oct 17 2003 Robert Love <rml@tech9.net>
44 - Make work without a build root
45 - Correctly install the right files
46 - Pass the RPM_OPT_FLAGS to gcc so we can build per the build policy
47 - Put some prereqs in
48 - Install the hotplug symlink to udev
49
50 * Mon Jul 28 2003 Paul Mundt <lethal@linux-sh.org>
51 - Initial spec file for udev-0.2.
52