chiark / gitweb /
[PATCH] fix segfault in parsing bad udev.permissions file
[elogind.git] / udev.spec
1 Summary: A userspace implementation of devfs
2 Name: udev
3 Version: 006_bk
4 Release: 1
5 License: GPL
6 Group: Utilities/System
7 Source: ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/%{name}-%{version}.tar.gz
8 ExclusiveOS: Linux
9 Vendor: Greg Kroah-Hartman <greg@kroah.com>
10 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
11 Prereq: /bin/sh, fileutils, hotplug
12
13 %description
14 udev is a implementation of devfs in userspace using sysfs and
15 /sbin/hotplug. It requires a 2.6 kernel to run properly.
16
17 %prep
18 %setup -q
19
20 %build
21 make CC="gcc $RPM_OPT_FLAGS"
22
23 %install
24 make DESTDIR=$RPM_BUILD_ROOT install
25
26 %clean
27 rm -rf $RPM_BUILD_ROOT
28
29 %files
30 %defattr(0644,root,root)
31 %doc COPYING README TODO ChangeLog
32 %attr(755,root,root) /sbin/udev
33 %attr(755,root,root) /udev/
34 %attr(755,root,root) /etc/udev/
35 %attr(0644,root,root) /etc/udev/udev.config
36 %attr(0644,root,root) /etc/udev/udev.permissions
37 %attr(-,root,root) /etc/hotplug.d/default/udev.hotplug
38 %attr(0644,root,root) %{_mandir}/man8/udev.8*
39
40 %changelog
41 * Fri Oct 17 2003 Robert Love <rml@tech9.net>
42 - Make work without a build root
43 - Correctly install the right files
44 - Pass the RPM_OPT_FLAGS to gcc so we can build per the build policy
45 - Put some prereqs in
46 - Install the hotplug symlink to udev
47
48 * Mon Jul 28 2003 Paul Mundt <lethal@linux-sh.org>
49 - Initial spec file for udev-0.2.
50