chiark / gitweb /
dgit: Set up a merge driver for debian/changelog. Closes:#769291.
[dgit.git] / debian / rules
index fece672aef8cbf8f3be503c4bf72fef9b0bacc78..fe5dd4c3d86dac86bf5ce0872ac53f889eb67531 100755 (executable)
@@ -3,7 +3,7 @@
 # dgit
 # Integration between git and Debian-style archives
 #
-# Copyright (C)2013 Ian Jackson
+# Copyright (C)2013-2015 Ian Jackson
 #
 # This program is free software: you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -29,3 +29,7 @@ override_dh_gencontrol:
         cd debian/dgit; \
         v=$$(perl -ne 'print if s/^version:\s+//i' DEBIAN/control); \
         perl -i -pe "s/UNRELEASED/$$v/g if m/###substituted###/" usr/bin/dgit
+
+override_dh_auto_install:
+       make install prefix=/usr DESTDIR=debian/dgit
+       make install-infra prefix=/usr DESTDIR=debian/dgit-infrastructure