chiark / gitweb /
git-debrebase: new-upstream: Fix error message for new version with bad syntax
[dgit.git] / debian / rules
index fece672aef8cbf8f3be503c4bf72fef9b0bacc78..baff8f897a2b35d12f6c1db02675507b49656141 100755 (executable)
@@ -3,7 +3,7 @@
 # dgit
 # Integration between git and Debian-style archives
 #
-# Copyright (C)2013 Ian Jackson
+# Copyright (C)2013-2016 Ian Jackson
 #
 # This program is free software: you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -29,3 +29,39 @@ override_dh_gencontrol:
         cd debian/dgit; \
         v=$$(perl -ne 'print if s/^version:\s+//i' DEBIAN/control); \
         perl -i -pe "s/UNRELEASED/$$v/g if m/###substituted###/" usr/bin/dgit
+
+globalperl=/usr/share/perl5
+
+override_dh_auto_install: specpkg_install_gdr specpkg_install_infra
+       make install prefix=/usr DESTDIR=debian/dgit
+
+specpkg_install_gdr: p=git-debrebase
+specpkg_install_gdr: pm=GDR
+
+specpkg_install_infra: p=dgit-infrastructure
+specpkg_install_infra: pm=Infra
+
+specpkg_install_%: tok=$*
+specpkg_install_%: specperl=/usr/share/dgit/$(tok)/perl5
+specpkg_install_%:
+       make install-$(tok) prefix=/usr DESTDIR=debian/$(p) perldir=$(specperl)
+#      # Most of the Perl modules in this package live in
+#      # $(specperl).  The exception is Debian::Dgit::Infra, which
+#      # lives in $(globalperl) and adds $(specperl) to @INC.
+       set -ex; \
+        base=debian/$(p); \
+        mod=Debian/Dgit/$(pm).pm; \
+        src=$${base}$(specperl)/$${mod}; \
+        dst=$${base}$(globalperl)/$${mod}; \
+        mkdir -p $${dst%/*}; \
+        mv -f $$src $$dst; \
+        perl -i -p -e 'next unless m/###substituted###/;' \
+               -e 'next unless s/^# (?=unshift \@INC,)//;' \
+               -e 'die unless s{q\{\S+\}}{q{$(specperl)}};' \
+                $$dst
+
+debian/tests/control: tests/enumerate-tests debian/tests/control.in
+       $< gencontrol >$@.new && mv -f $@.new $@
+
+debian/tests/control: tests/lib-core tests/lib-restricts
+debian/tests/control: tests/tests $(wildcard tests/tests/*[^~#])