chiark / gitweb /
Copyright: Add notices to some more of the (larger) files
[dgit.git] / debian / rules
index fe5dd4c3d86dac86bf5ce0872ac53f889eb67531..6580f96ebf13618980465ab89873310e76fd8b91 100755 (executable)
@@ -3,7 +3,7 @@
 # dgit
 # Integration between git and Debian-style archives
 #
-# Copyright (C)2013-2015 Ian Jackson
+# Copyright (C)2013-2016 Ian Jackson
 #
 # This program is free software: you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -33,3 +33,9 @@ override_dh_gencontrol:
 override_dh_auto_install:
        make install prefix=/usr DESTDIR=debian/dgit
        make install-infra prefix=/usr DESTDIR=debian/dgit-infrastructure
+
+debian/tests/control: tests/enumerate-tests debian/tests/control.in
+       $< gencontrol >$@.new && mv -f $@.new $@
+
+debian/tests/control: tests/lib-core tests/lib-restricts
+debian/tests/control: tests/tests $(wildcard tests/tests/*[^~#])