chiark / gitweb /
i18n: Call po/Makefile directly from debian/rules
[dgit.git] / debian / rules
index baff8f897a2b35d12f6c1db02675507b49656141..614fb7a55e0d465134b82d9dc63ad41390b23acd 100755 (executable)
@@ -30,10 +30,16 @@ override_dh_gencontrol:
         v=$$(perl -ne 'print if s/^version:\s+//i' DEBIAN/control); \
         perl -i -pe "s/UNRELEASED/$$v/g if m/###substituted###/" usr/bin/dgit
 
+override_dh_auto_clean:
+       dh_auto_clean
+       make -C po clean
+
 globalperl=/usr/share/perl5
 
 override_dh_auto_install: specpkg_install_gdr specpkg_install_infra
        make install prefix=/usr DESTDIR=debian/dgit
+       make -C po install prefix=/usr DESTDIR=../debian/tmp \
+               SUPPRESS_PO_UPDATE=1 S=''
 
 specpkg_install_gdr: p=git-debrebase
 specpkg_install_gdr: pm=GDR