chiark / gitweb /
test suite: downstream-gitless: Run t-ok
[dgit.git] / debian / changelog
index 0c377e5f1b3b73cbf75b6d3f2569fd292f878932..fac9fc7b75115fc86b4a32d080fe6a6c899ddd43 100644 (file)
-dgit (2.9~) unstable; urgency=low
+dgit (3.0~) unstable; urgency=medium
 
-  * Split brain mode: Fix --new.  Closes:#842577.
+  Protocol change:
+  * Dgit: field now records the nominal distro name, and a hint
+    for a tag and url where the git objects (including any rewrite
+    map) can be fetched.
+  * Use this information, where provided.  Closes:#850431.
+
+  Bugfixes:
+  * dgit config handling: Honour command-line and context-provided
+    suite and distro more reliably and consistently.
+
+  Minor new feature:
+  * distro alias facility in config space.  (Primarily for testing.)
+  * Undocumented --config-lookup-explode= feature.  (For testing.)
+
+  dgit-badcommit-fixup: 
+  * Do not investigate symrefs.  Closes:#850547.
+
+  * Improve debugging output a bit.
+
+  Test suite:
+  * Internal improvements.
+  * badcommit-rewrite: Fix operation using installed version of fixup.
+  * Arrange to pass --debug-quick-random to gpg-agent.
+  * Strip block count out of find -ls output - it is unstable!
+  * gbp-orig: Add a missing -m, without which git would run an
+    editor if stdout was a tty (!)
+  * Add t-stunt-parsechangelog to a few tests which were missing it.
+  * Tests for the new protocol feature.
+  * Fail tests if we look up any configuration relating to Debian.
+
+ --
+
+dgit (2.16.2) unstable; urgency=low
+
+  dgit-badcommit-fixup: 
+  * Fix crash when running for 2nd time in bare repo.
+  * In --check mode, exit with status 2 if things are not fine.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Sat, 07 Jan 2017 13:31:50 +0000
+
+dgit (2.16.1) UNRELEASED; urgency=low
+
+  * dgit-badcommit-fixup: New mode --check which is readonly.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Sat, 07 Jan 2017 13:04:49 +0000
+
+dgit (2.16) unstable; urgency=low
+
+  Dealing with fallout from #849041:
+  * Provide dgit-badcommit-fixup history-rewriting script.
+  * New rewrite map feature, which allows dgit git server to adjust
+    clients' interpretation of Dgit fields, so that history-rewriting is
+    effective.  (Feature is only partially implemented right now -
+    enough to dig current Debian users out of the hole.)  Re:#850431.
+
+  Test suite:
+  * New test case for history-rewriting.
+  * Change `local foo=$(bar)' idiom to `local foo; foo=$(bar)' since
+    the former does not trip set -e even if bar fails :-(. 
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Fri, 06 Jan 2017 20:46:30 +0000
+
+dgit (2.15) UNRELEASED; urgency=high
+
+  Infastructure:
+  * Prevent introduction of new commits which lack `committer'
+    information.  Ie, prevent the reception of new commits afflicted by
+    #849041.  Existing commits are tolerated.
+
+  Test suite:
+  * Be much stricter about messages from git-fsck.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Thu, 05 Jan 2017 18:20:23 +0000
+
+dgit (2.14) unstable; urgency=critical
+
+  CRITICAL BUGFIX:
+  * Do not generate bogus commits with --overwrite or import-dsc.
+    Closes:#849041.
+
+  Test suite:
+  * Run a lot of git-fsck.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Wed, 04 Jan 2017 22:52:55 +0000
+
+dgit (2.13) unstable; urgency=high
+
+  Changed behaviour:
+  * quilt fixup: Permit creation of patches which delete files, by psssing
+    --include-removal to dpkg-source, and tolerating it when we do our
+    quilt fixup analysis.  dpkg-source has supported this since at least
+    stretch.  Closes:#848901.
+
+  Error messages:
+  * Improve "cannot represent change" message: print the git old and new
+    modes too.
+
+  Bugfix:
+  * Import: Switch back to unpa branch on patch import iterations.
+    In particular, do not fail utterly if dpkg-source and gbp disagree.
+    Closes:#848843.
+
+  Documentation [Sean Whitton]:
+  * dgit-maint-gbp(7): Remove reference to closed bug.  Closes:#848725.
+  * dgit-sponsorship(7): Update in light of fixed #844129.  Closes:#848789.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Wed, 21 Dec 2016 01:32:41 +0000
+
+dgit (2.12) unstable; urgency=high
+
+  Changed behaviours:
+  * By default, generate a DEP-14 tag as well as a dgit archive/*
+    tag, even in non-split-view quilt modes.  Closes:#844129.
+  * Version tags mangling: Protect dots, as per proposed update to DEP-14.
+
+  Documentation:
+  * dgit-maint-merge(7): Explain how to change to this workflow
+    from an existing git workflow.  [Sean Whitton]  Closes:#847807.
+  * dgit-maint-native(7): Clarify that we mean native source format.
+    [Phil Hands]  Closes:#847987.
+
+  Error messages:
+  * Slightly better message when .dsc not found.  Apropos of #844128.
+  * Give better advice if .dsc/.changes signing fails: if no changes
+    are needed to the package, user may indeed just debsign and dput.
+    Closes:#844131.
+  * Produce better error reporting when absurd git wrapper fails
+    on a patch during .dsc import.  Apropos of #848391.
+
+  Bugfixes:
+  * If we cannot hardlink origs into our extraction area, use symlinks
+    instead.  Closes:#844570.
+  * Suppress some leftover debugging output from import-dsc.
+    Closes:#847658.
+  * Do not fail when cloning a package containing dangling symlinks.
+    Closes:#848512.
+  * Do not fail to import a .dsc containing patches which patch files
+    multiple times, due to #848611.  Closes:#848391.
+  * Do not fail to import a .dsc containing patches to .git/ (!)
+  * infra: dgit-repos-policy-debian which broke due to recent git setting
+    GIT_ALTERNATE_OBJECT_DIRECTORIES in the pre-receive-hook.
+    (fixes test suite regression in stretch).
+
+  Test suite:
+  * Provide and use stunt lintian and debuild, to avoid lintian
+    complaining about our stupid test packages.
+    (fixes test suite regression in stretch).
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Mon, 19 Dec 2016 17:35:18 +0000
+
+dgit (2.11) unstable; urgency=medium
+
+  Documentation:
+  * dgit-user(7): Better explanation of combined suites (comma syntax).
+    Thanks to Sean Whitton for review and suggestions.
+  * dgit(1), dgit(7): Better reference docs for combined suites.
+  * dgit(1): Improve formatting of rpush section.
+
+  Test suite:
+  * Replace make in Test-Depends with build-essential.  Most of the tests
+    do in fact run dpkg-buildpackage which bombs out if build-essential is
+    missing.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Tue, 08 Nov 2016 22:41:29 +0000
+
+dgit (2.10) unstable; urgency=medium
+
+  New features:
+  * Support the Debian *-security suites.
+  * New comma-separated multiple-suite merging facility (readonly),
+    so that users can easily track "jessie, or jessie-security".
+  * dgit-user(7): Suggest `dgit clone P jessie,-security'.
+
+  Bugfixes:
+  * Cope when an orig tarball is a tarbomb.  Ie, if it contains
+    other than one single directory toplevel.  Closes:#843422.
+  * Actually honour the branch name, if we are on dgit branch, to specify
+    the suite, as documented in the manpage.
+  * When cloning a distro which has no git server, correctly leave
+    the user on the local dgit branch, not on `master'.
+  * Fix an unconditional print that was supposed to be a printdebug:
+      origs <blah>.orig.tar.gz f.same=1 #f._differ=-1
+  * Print a slightly better message if .git found in orig tarball(s).
+
+  Test suite:
+  * Test suite: Add fakeroot and make to Test-Depends.  These aren't
+    necessarily pulled in by anything else.  (dpkg-dev Recommends
+    build-essential.  But we don't actually need build-essential.)
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Tue, 08 Nov 2016 01:08:51 +0000
+
+dgit (2.9) unstable; urgency=medium
+
+  New features:
   * During push, automatically calculate which .origs are required,
     so user never needs [--ch:]-sa or [--ch:]-sd.  Closes:#829116.
-  * Properly look for .origs etc. in .., fetching them less often.
-    Closes:#842386.
   * New import-dsc feature.
-  * Test suite: Explicitly configure user.name and user.email, so
-    that tests work when environment doesn't have defaults.
-    Closes:#842279 (I hope).
   * New option --dgit-view-save= for split view quilt modes.
     In particular, means that the output of a split view quilt-fixup
     is left somewhere useful.
@@ -19,6 +207,21 @@ dgit (2.9~) unstable; urgency=low
     about possible skew).
   * dgit gbp-build will arrange to let gbp buildpackage generate
     .orig tarballs if it seems applicable.  Closes:#841094.
+
+  Documentation improvements:
+  * dgit-*(7).  Many new tutorial manpages, several written and many
+    improved by Sean Whitton.
+  * dgit(7): Substantial updates, including documenting split view.
+  * dgit(1): Better cross-references.
+  * dgit(1): Remove obsolete workflow information.
+  * dgit(1): Improved BUGS section.
+  * Fix changelog entry for SIGPIPE to correctly mention
+    Closes:#841090.
+
+  Bugfixes:
+  * Split brain mode: Fix --new.  Closes:#842577.
+  * Properly look for .origs etc. in .., fetching them less often.
+    Closes:#842386.
   * Reject `dgit pull' in split view quilt modes, to avoid
     creating unfortunate wreckage on non-dgit-view branches.
     Closes:#842608.
@@ -26,14 +229,13 @@ dgit (2.9~) unstable; urgency=low
     like testing.  Closes:#842621.
   * Properly fetch all archive dgit view tags, as we intended.
   * Actually provide a -p (--package=) option (!)
-  * dgit-*(7).  Many new tutorial manpages, several written and many
-    improved by Sean Whitton.
-  * dgit(7): Substantial updates, including documenting split view.
-  * dgit(1): Better cross-references.
-  * dgit(1): Remove obsolete workflow information.
-  * dgit(1): Improved BUGS section.
 
- --
+  Test suite fixes:
+  * Test suite: Explicitly configure user.name and user.email, so
+    that tests work when environment doesn't have defaults.
+    Closes:#842279 (I hope).
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Mon, 31 Oct 2016 12:47:18 +0000
 
 dgit (2.8) unstable; urgency=medium
 
@@ -121,7 +323,7 @@ dgit (2.2) unstable; urgency=low
   * Fix config relating to Debian to actually make split brain mode
     work.  Closes:#841085.
   * Detect SIGPIPE (and SIGCHLD) being blocked or ignored.
-    Closes:#841085.
+    Closes:#841090.
 
  -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Mon, 17 Oct 2016 17:31:18 +0100