chiark / gitweb /
dgit: Use GIT_COMMITTER_DATE for automatic patch
[dgit.git] / debian / changelog
index 984e6cb1503d630ab3384f28a0bef3257fd4f1ad..ee5f7d0b5b56748199a6ae383f22ecac7e685669 100644 (file)
@@ -8,8 +8,32 @@ dgit (1.5~~) unstable; urgency=medium
     to change for the dgit user.
 
   New checks and improved behaviours:
-  * In dgit sbuild, check that the set of .changes files found is as we
-    expect, before calling mergechanges
+  * When running dpkg-buildpackage, cope if user specified -g or -G.
+  * dgit sbuild: check that the set of .changes files found is as we
+    expect, before calling mergechanges.
+  * dgit sbuild: Rename the used-up .changes files to `.inmulti' to
+    avoid accidental use of the wrong one (by software, or by users).
+  * dgit sbuild: Check that the binary .changes file doesn't contain a
+    .dsc.
+  * Introduce --rm-old-changes to delete previous builds' changes files.
+  * Remove any pre-existing _source.changes file before building source,
+    as a safety check.
+  * No longer tolerate a multitude of .changes files when doing push.
+    Instead, insist on a single one.
+  * dgit sbuild no longer deletes extranious .changes files; instead
+    we rely on --rm-old-changes, or failing that, fail early.
+  * When doing quilt linearisation, treat upstream .gitignores not
+    in the toplevel the same way we treat ones in the toplevel.
+  * When automatically generating quilt patch, honour GIT_COMMITTER_DATE
+    for filename creation (makes filename deterministic in test suite).
+
+  Infrastructure:
+  * Better error handling in dgit-repos-policy-debian.
+  * dgit-repos-policy-debian.: fix git-cat-file-handling with multiple
+    taints in db (!).
+
+  Documentation:
+  * Document the dgit-distro.DISTRO.quilt-mode config setting.
 
   Bugfixes:
   * When cleaning up after failed clone, stat the to-be-cleaned-up
@@ -22,6 +46,8 @@ dgit (1.5~~) unstable; urgency=medium
     messages.  Closes:#800078.
   * Pass --ch:* and -v options to dpkg-buildpackage when building
     source.  Fixes bad Perl poetry syntax.  Closes:#829121.
+  * When synthesing a commit from a .dsc from the archive, stop
+    internal git reset from printing a confusing message about HEAD.
 
   Test suite:
   * When sbuild fails, do not crash due to sed not finding the log
@@ -36,6 +62,11 @@ dgit (1.5~~) unstable; urgency=medium
     zealot is very slow and we need to give the other processes time
     to rollback and release the lock.
   * Test quilt single-debian-patch.
+  * Provide `tartree-edit gitfetchinfo' etc. to help with comparing
+    different test case git working tree tarballs.
+  * Test dgit-repos-policy-debian with multiple (identical, as it happens)
+    existing taints.
+  * Provide better log output for certain failures.
 
  --