chiark / gitweb /
Revert "Switch to using dgit@git.debian.org (and dgit-repos-server) by default."
[dgit.git] / debian / changelog
index 7e2b85f553a398916593abd64ff5cfd82213d5fe..c10a7137fcf1b2663e7cc28347a97ece4c5cebc3 100644 (file)
@@ -1,3 +1,325 @@
+dgit (0.22~experimental1) experimental; urgency=low
+
+  * Bring forward push of the version tag ref so it happens alongside
+    the push of the suite branch ref.
+  * Include canonicalised suite name in signed tag message.
+
+  * New git-check and git-create methods "true" which are no-ops.
+  * test-dummy-drs `distro': for testing dgit-repos-server.  WIP.
+  * dgit-repos-server: WIP
+  * New script tests/using-intree for running tests on the source tree.
+
+ --
+
+dgit (0.21) unstable; urgency=medium
+
+  Bugfixes relating to unclean trees:
+  * Run a clean (of the specified type) before any build operation; do
+    this with `dpkg-buildpackage -T' clean if necessary, so -wd now works
+    with all the building methods.
+  * Refuse to do quilt fixup (explicitly requested, or as a result of
+    build) if the tree contains ignored files.  Closes:#731632.
+
+  Error message improvements:
+  * Use failedcmd to report errors when ssh psql fails.  Closes:#734281.
+  * failedcmd prints $us, not $_[0] - ie, dgit doesn't pretend,
+    in the error message, to be its child.
+  * Do not report the (irrelevant) $? when madison parsing fails.
+
+  Better workflow flexibility:
+  * Provide --build-products-dir option (and corresponding semantics
+    for -C) to specify where to find the files to upload.  Closes:#731633.
+
+  Support for Debian backports suites:
+  * New quirks infrastructure in configuration and internals,
+    for suites (or perhaps distros) which are a bit like others.
+  * Use correct default archive location.
+  * Compute "-v" option default value correctly.
+  * Closes:#733954.
+
+  Packaging improvement:
+  * Add `Testsuite: autopkgtest' to debian/control.  (This will only have
+    the right effect with recent enought dpkg; it will generate a harmless
+    warning with earlier versions of dpkg.)
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Sun, 19 Jan 2014 02:14:25 +0000
+
+dgit (0.20) unstable; urgency=high
+
+  * Use newest (not oldest) version currently in suite when calculating
+    what value to use for -v<version> by default.  Closes:#732781.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Sat, 21 Dec 2013 19:13:56 +0000
+
+dgit (0.19) unstable; urgency=low
+
+  Testing facilities:
+  * Provide "test-dummy" distro with "dummycat" access method.
+  * Provide a selection of autopkgtest (DEP-8) tests.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Wed, 27 Nov 2013 18:27:17 +0000
+
+dgit (0.18.2) unstable; urgency=high
+
+  Bump archive upload urgency to high.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Sun, 24 Nov 2013 17:42:57 +0000
+dgit (0.18.1) unstable; urgency=low
+
+  Bugfixes:
+  * sshpsql archive query method passes LANG=C.  Closes:#729788.
+  * Subcommand program or argument options containing hyphens work.
+    (Eg, --dpkg-buildpackage:blah was previously incorrectly rejected.)
+
+  Packaging fixes:
+  * Depend on dput.
+  * Depend on curl | wget, as dget needs one of those.  (The dput package,
+    which contains dget, doesn't require them because dput itself works
+    without.)
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Sun, 24 Nov 2013 17:36:03 +0000
+
+dgit (0.18) unstable; urgency=low
+
+  Major new feature:
+  * Remote push (dgit rpush), a la debsign -r.  Closes:#721185.
+
+  Improved behaviours:
+  * dgit build, by default, uses the archive to find out what the correct
+    -v<version> option is to pass to dpkg-genchanges.  Closes:#727200.
+  * Abolish the sshdakls method and replace it with sshpsql: that is, ssh
+    (to coccia, by default) and run sql commands on the ftpmaster
+    database.  This is faster and has fewer bugs but is vulnerable to db
+    schema changes.  Closes:#726955.  Closes:#720170.  Closes:#720176.
+  * When generating git tags, quote the (uncanonicalised) changelog's
+    Distribution field as the suite.
+  * Command execution reports from --dry-run go to stderr.
+
+  Other new features:
+  * Support --gpg=... to provide a replacement command for gpg.
+  * Support --ssh=... and --ssh:... to affect how we run ssh.
+
+  Bugfixes:
+  * When using sbuild, pass the arguments to mergechanges in the right
+    order so that we use the correct Description (the _source one,
+    not the one from sbuild which didn't get e.g. -v<version>).
+  * push actually takes an optional suite, like it says in the synopsis.
+    Closes:#727125.
+  * Fix dgit --damp-run sbuild to actually work.
+  * Fix the "shellquote" internal subroutine.  The bugs in it ought not to
+    have caused any real trouble in previous versions of dgit.
+
+  Documentation and message fixes:
+  * manpage: Clarify comments about orig tarballs.  Closes: #723605.
+  * manpage: Remove comment in BUGS about lack of policy docs
+    for Dgit field, which is specified now.  Closes:#720201.
+  * manpage: Make discussion of --existing-package less scary.  The
+    default archive access method no longer needs it.  Closes:#720171.
+  * Mention "git merge", not "git-merge", in helpful message.
+    Closes:#725632.
+
+  Internal and debugging improvements:
+  * Report chdir actions in debugging output.
+  * Improvements to implementation of --dry-run and --damp-run.
+  * Some code motion and cleanups.
+
+  Note: changelog entries for the following versions, which were uploaded
+  to Debian experimental, have been collapsed into this single entry:
+    0.18~experimental2 0.18~experimental1
+    0.17~experimental7 0.17~experimental6 0.17~experimental5
+    0.17~experimental4 0.17~experimental3 0.17~experimental2
+    0.17~experimental1
+    0.16~experimental3 0.16~experimental2 0.16~experimental1
+  We do describe here all the changes since 0.17.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Sat, 09 Nov 2013 10:12:13 +0000
+
+dgit (0.17) unstable; urgency=high
+
+  * Do not grobble around in .git/refs/; instead, use git-show-ref.
+    This avoids breaking when git makes packed refs.  Closes:728893.
+  * Clarify error message for missing refs/remotes/dgit/dgit/<suite>.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Thu, 07 Nov 2013 00:02:47 +0000
+
+dgit (0.16) unstable; urgency=high
+
+  * Format `(3.0) quilt' fixup does not mind extraneous other files
+    in the build tree (e.g., build products and logs).  Closes: #727053.
+  * Set autoflush on stdout, to get better ordering of debugging
+    etc. output when stdout is redirected.
+  * New --damp-run mode, for more convenient and fuller testing etc.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Tue, 22 Oct 2013 13:06:54 +0100
+
+dgit (0.15) unstable; urgency=low
+
+  * Better handling of packages pushed using dgit and stuck in NEW.
+    (And, use of `--new' is not needed with fetch.)  Closes: #722199.
+  * More comprehensive warnings in many cases of archive skew.
+  * Implement `dgit help' as well as `--help'.  Closes: #721661.
+  * Provide `dgit version' and `--version'.  Closes: #721654.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Thu, 12 Sep 2013 00:14:05 +0100
+
+dgit (0.14) unstable; urgency=low
+
+  * Include package name in tag message.
+  * Create directory .git/dgit when needed during build.  Closes: #721428.
+  * Add Vcs-Git and Vcs-Browser [Richard Hartmann].  Closes: #721404.
+    These fields refer to the development branch, "master", on alioth,
+    not to the dgit suite refs (which are not accessible to git clone).
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Sun, 01 Sep 2013 18:30:44 +0100
+
+dgit (0.13) unstable; urgency=low
+
+  * Reuse already-downloaded .orig files after checking their hashes.
+    Closes: #720526.  (This introduces a dependency on Digest::SHA.)
+  * Do not always pointlessly fetch the .dsc twice.  (That code was
+    erroneously duplicated during editing, apparently.)
+  * Remove DGET_UNPACK from the environment in case the user has set it.
+  * Remove scary warning from Description.
+  * When uploading to Debian, tell dput to upload to "ftp-master".  This
+    avoids problems with derivatives whose dput has a different default.
+    Closes: #720958.
+  * Fix some bugs in dgit fetch --dry-run which made dgit push
+    --dry-run often not work at all.
+  * Update the local tracking branch for the dgit remote, when pushing.
+    Closes: #720956.
+  * Fix references in manpage to old Vcs-Dgit-Master field name.
+  * Reorganise manpage sections to be in a more conventional order.
+  * New manpage section on FILES IN THE SOURCE PACKAGE BUT NOT IN GIT.
+    Closes: #721186.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Thu, 29 Aug 2013 00:27:23 +0100
+
+dgit (0.12) unstable; urgency=low
+
+  * Cope with packages with epoch.  Closes: #720897.
+  * Improve error message for non-fast-forward push.  Closes: #720896.
+  * New --ignore-dirty option to skip noncritical check.  Closes: #720895.
+  * New --no-quilt-fixup option to suppress quilt fixup.  RTFM.
+  * Add Closes line for #720595 to changelog entry for 0.11.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Mon, 26 Aug 2013 16:50:39 +0100
+
+dgit (0.11) unstable; urgency=low
+
+  * Location of dgit-repos is now git.debian.org:/git/dgit-repos/repos.
+    Closes: #720525.  The rename on the server side will break older
+    versions of dgit.
+  * Fix bug which would make quilt patch fixup fail if git status
+    produced "M" lines.
+  * Autogenerated quilt patch fixup patch Description contains several
+    recent git commits, rather than implying that the patch corresponds
+    exactly to the top git commit.
+  * Use "ftp.debian.org" not "http.debian.net" as the default Debian
+    archive.  (http.debian.net tends to defeat certain kinds of cacheing,
+    and can also have more skew.)
+  * dgit build uses dpkg-buildpackage; there is a dgit git-build
+    for using git-buildpackage.  Closes: #720595.
+  * Better error message for use of UNRELEASED suite.  Closes: #720523.
+  * Do not canonicalise suite more than once.  Related to: #720526.
+  * Fix a badly open-coded copy of check_not_dirty.  Closes: #720524.
+  * Fix some bugs in building (eg build-source would fail to do the quilt
+    fixup; the --clean check in build was wrong).
+  * Add missing dependency on realpath.
+  * git-build (git-buildpackage wrapper) does not bother canonicalising
+    the suite if --git-ignore-branch is used.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Sun, 25 Aug 2013 17:00:43 +0100
+
+dgit (0.10) unstable; urgency=low
+
+  * Create .pc/applied-patches - do not empty it (!)
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Sun, 25 Aug 2013 00:51:50 +0100
+
+dgit (0.9) unstable; urgency=low
+
+  * New cleaning arrangements.
+  * More comprehensive workaround for `3.0 (quilt)'.
+  * In push, double-check the .changes against the changelog.
+  * Better error when source package contains .git.  Closes: #720555.
+  * Change our .dsc field name to `Dgit'.  Relevant to #720201.
+  * Fix bug handling our synthetic merges when we see them in
+    the remote suite branch.
+  * `3.0 (quilt)' fixup creates .pc/applied-patches since modern
+    dpkg-source creates it even though old ones didn't always.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Sat, 24 Aug 2013 18:49:02 +0100
+
+dgit (0.8) unstable; urgency=low
+
+  * Fix comparison of archive's .dsc's hash and git branch head
+    to DTRT.
+  * When creating repos in dgit-repos (using the ssh-cmd method),
+    copy _template rather than using mkdir and git init.
+    Closes: #720522.
+  * In push, do git fetch as well as archive fetch, or archive
+    fetch can fail.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Fri, 23 Aug 2013 12:24:09 +0100
+
+dgit (0.7) unstable; urgency=low
+
+  * If dak ls, or rmadison, reports multiple versions, look for them
+    all, and pick the newest .dsc that doesn't give 404.
+  * Manpage formatting fix.
+  * Name the local remote tracking branch remotes/dgit/dgit/<suite>
+    so that we avoid a warning from git about ambiguous branch names.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Thu, 22 Aug 2013 18:29:10 +0100
+
+dgit (0.6) unstable; urgency=low
+
+  * Allow fetching when archive has out-of-date git hash in .dsc.
+    Closes: #720490.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Thu, 22 Aug 2013 16:02:10 +0100
+
+dgit (0.5) unstable; urgency=low
+
+  * Upload to unstable, as this version mostly works.  (All the RC
+    bugs of which I'm aware are now properly represented in the BTS.)
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Thu, 22 Aug 2013 15:38:00 +0100
+
+dgit (0.4~pre2) experimental; urgency=low
+
+  * Mangle debian/<version> tags the way git-buildpackage does
+    (as of git-buildpackage 0.5.5, 3c6bbd0f4992f8da).
+  * Support dgit-distro.<distro>.keyid config option.
+  * Revert change to ssh to alioth CNAME, as the recommended CNAME
+    is to something with no write access to the fs and the new CNAME
+    has not yet been set up.  This reintroduces #720172 :-/.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Thu, 22 Aug 2013 15:31:17 +0100
+
+dgit (0.4~pre1) experimental; urgency=low
+
+  * Use dgit.debian.net vhost on alioth.  Closes:#720172.
+  * Usage message.  Closes:#720085.
+  * Provide "dgit sbuild".
+  * Assorted manpage fixes and improvements.
+  * Fail if a required config item is missing.
+  * Much better error messages.
+  * Better error checking when parsing RFC822-style control data.
+  * Better checking that the supplied .dsc and debian/changes correspond.
+  * Ordering improvement in push: don't add dsc field until git push done.
+  * New --distro option (helps with unknown suites).
+  * Bugfixes.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Thu, 22 Aug 2013 13:36:44 +0100
+
+dgit (0.3) experimental; urgency=low
+
+  * New version which appears to be able to sort of work at least
+    some of the time.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Sat, 17 Aug 2013 09:18:04 +0100
+
 dgit (0.2) experimental; urgency=low
 
   * New version which might actually work but probably won't.