chiark / gitweb /
Run debian/rules debian/tests/control
[dgit.git] / debian / changelog
index 2e6e7447bc1666834952118617849ab9fbfe54a2..bd5ab63e2cfe8b4fcb3167ffe26a9ce25e905e5d 100644 (file)
@@ -1,4 +1,4 @@
-dgit (1.1) unstable; urgency=low
+dgit (1.1~~) unstable; urgency=low
 
   * Fix Vcs-Git and Vcs-Browse to refer to chiark.  (The dgit-repos on
     alioth aren't suitable right now because the master there can
@@ -28,6 +28,45 @@ dgit (1.1) unstable; urgency=low
   * Work around #793471 (madness with $SIG{__WARN__} and Perl's system
     builtin): move $SIG{} setting into setup_sigwarn in Dgit.pm, and
     check getppid.
+  * Make warnings fatal in dpkg-repos-admin-debian, dgit-ssh-dispatch
+    (using setup_sigwarn).
+  * Make warnings fatal in tstunt/dpkg-parsechangelog (directly).
+  * When source package contains things called .git (even files, and even
+    in subdirectories), remove them.  Closes:#793671.
+  * Introduce more sophisticated protocol negotiation for rpush.
+  * Do not quote `:' in shellquote.
+  * Test suite: Honour DGIT_TEST_DEBUG=''.
+  * Print a supplementary message when push fails, giving advice to
+    the user about how to retry.  Closes:#793144.
+  * Honour dgit-distros.DISTRO.cmd-CMD and .opts-CMD.  Closes:#793427.
+  * Slurp in entire git config, for better performance.
+  * With -DDDD, print out all gitcfg references (copious!)
+  * Fix a debug message in the obsolete sshpsql archive access driver.
+  * Make configuration able to prevent dpkg-mergechangelogs setup.
+  * Provide dgit setup-new-tree (like dpkg-setup-mergechangelogs
+    but only does it if not disabled in config).
+  * Set up git user.email and user.name from distro access config
+    or DEBEMAIL/DEBFULLNAME.  Closes:#793410.
+  * Work around curl -sS -I printing `HTTP/1.0 200 Connection established'
+    before the actual header, so dgit works with https_proxy set (!)
+  * When key to use not specified any other way, use the debian/changelog
+    trailer line.  Closes:#793423.
+  * Honour --git= (mostly).
+  * Test suite: More automatic enumeration of tests.
+  * Rename `git-build' operation to `gbp-build' to make it clearer what
+    it's for.  Keep the old name as an alias.
+  * Show `dgit sbuild' in usage message.
+  * When we are using dpkg-buildpackage to clean before using it to also
+    do the build, let it do its cleaning thing as part of its run, rather
+    than running it twice.  When we are _not_ supposed to be using
+    dpkg-buildpackage to clean, but we are running it to do the build,
+    pass -nc.
+  * Also suppress spurious runs of the clean target when building using
+    git-buildpackage.
+  * Test suite: Provide tests which check that all our various build
+    operations run the right targets as expected (ie, that we are massaging
+    the arguments to dpkg-buildpackage, and suppressing our clean target,
+    etc., correctly).
 
  --