chiark / gitweb /
Push replay prevention protocol: Rename "supersedes" to "previously", as not necessar...
[dgit.git] / debian / changelog
index ddd1b2e172d1278c405e49e3777dfd79caaaa309..b0587c6f43f458c528e5e49194b67be38343a6f2 100644 (file)
@@ -1,9 +1,143 @@
-dgit (0.22~experimental1) experimental; urgency=low
+dgit (0.23~) unstable; urgency=low
 
-  * 
+  * Check for new dgit git service on dgit-git.debian.net (ie
+    gideon.debian.org), with transition plan based on diversion feature.
+    Closes:#720172.
+
+  * New handling for .pc directory: dgit history now no longer contains
+    .pc at all.  It is deleted whenever we find it.  (When doing quilt
+    fixup, we recreate a suitable .pc in a temporary directory so that we
+    can do dpkg-source --comit.)  Closes:#764606.  INCOMPATIBLE CHANGE -
+    older versions of dgit will have trouble with these git histories.
+
+  * Replace many calls to stat with new wrapper stat_exists; improves
+    error handling and simplifies the code.
+
+  * Fix handling of rmadison-based and gitless distros (e.g., Ubuntu).
+
+  * Distro access configuration handling changes (should not be noticeable
+    to most users).
+
+  * Add :..; prefix to ssh remote commands, for the benefit of future
+    forced command wrappers.  Implicitly, this defines a new ssh-based
+    command protocol.  Closes:#720174, #720175.
+
+  * dgit-repos-server: Handle ' ' in SSH_ORIGINAL_COMMAND (which some
+    git versions send, sigh).
+
+  * New dgit-ssh-dispatch infrastructure script for use on dgit repos
+    server as part of ssh forced command.
+
+  * Test suite restructuring to support new tests.
+
+  * Add missing `gpgv' to test dependencies in debian/tests/control.
+
+  * New dgit-infrastructure binary package containing dgit-repos-server et
+    al.  Client users probably don't want this stuff.  Also, it provides a
+    convenient way to publish the dependencies.
+
+  * When generating quilt patches, try to linearise the git history into a
+    series of individual new patches for debian/patches.  Closes:#770710.
+
+  * Better documentation for quilt series handling.
+
+  * Strip `-b <branch>' from contents of Vcs-Git header, when setting up
+    the vcs-git remote.  Closes:#759374.
+
+  * Do not offer wget as an alternative dependency to curl.  We always
+    unconditionally invoke curl and have no code to use wget.
+    Closes:#760805.
+
+  * Complain about lack of cuddled values for value-taking single-letter
+    options, rather than thinking the user meat an empty value.
+    Closes:#763332.
+
+  * Reject (rather than ignoring) further options merged witht -wn, -wg,
+    -wd.
+
+  * Document in manpage under `dgit push' that it is best to build with
+    dgit too.  Closes:#763333.
+
+  * Fix inaccurate error message when archive's git hash is not an
+    ancestor of git repo's git hash.
+
+  * Use ftpmasterapi archive query method.  (Closes:#727702.)
+
+  * Turn all perl warnings into errors using $SIG{__WARN__}.
+
+  * Show git config queries only with debuglevel 3 (-DDD) and higher.
 
  --
 
+dgit (0.22.1) unstable; urgency=high
+
+  * Use Dpkg::Version::version_compare everywhere, not
+    Dpkg::Version::version_compare_string.  The latter is entirely wrong,
+    meaning that dgit would get many version comparisons wrong.
+    Closes:#768038.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Tue, 04 Nov 2014 12:46:40 +0000
+
+dgit (0.22) unstable; urgency=medium
+
+  Bugfixes:
+  * Clone removes destination directory on error.  Closes:#736153.
+  * Work with wheezy-backports (and keep squeeze-backports working too).
+    Closes:#736524.
+  * Work in read-only no-git-history mode with Ubuntu.  You still have
+    to pass -dubuntu.  Closes:#751781.
+  * Use mirror.ftp-master.debian.org DNS alias rather than coccia.
+    Closes:#752602.
+  * Check hashes of files ourselves rather than running dget to
+    re-retreive the .dsc.
+  * Check SHA-256 of .dsc against hash from archive_query (ie projectb)
+    rather than letting dpkg-source do a signature verification.
+    Closes:#737619.  Closes:#737625.
+  * Treat .dsc as bytes, just like everything else, rather than letting
+    HTTP::Message convert it to a Perl unicode string which the rest of
+    the program mishandles.  Closes:#738536.
+
+  Minor improvements:
+  * Include canonicalised suite name in signed tag message.
+  * Mention cross-version dgit rpush incompatibility in manpage.
+  * Check for rpush protocol version incompatibility and crash early
+    if incompatible.
+  * New script tests/using-intree for running tests on the source tree.
+  * Do not spew diff output to terminal (by default).  Print sensible
+    message instead.  Closes:#736526.
+  * Print better message for lack of configuration settings.
+  * Document that dgit rpush needs gnupg and your public key on the build
+    host.  Closes:#736529.
+  * Fix a manpage reference to `--dget=' where `--dgit=' was intended.
+  * Provide t-archive-process-incoming and t-archive-query subroutines for
+    regression test scripts to use.
+  * Print better message for unknown operations.
+  * Provide `dgit clean'.  Closes:#736527.
+  * When cloning, set up a remote `vcs-git' from the package's Vcs-Git
+    (and put an appropriate caveat in the manpage).  Closes:#740687.
+    Closes:#740721.
+  * Improve error message for .dsc having already been signed (iff
+    using libdpkg-perl 1.17.x).  Closes:#731635.
+  * Improve error message for .dsc parsing failures more generally.
+  * Better reporting of child exit statuses (esp. deaths due to signals).
+  * In rpush, on protocol error talking to build host, check if the
+    subprocess died and report differently if so.  Closes:#736528.
+  * Fixed a manpage typo.
+  * When tests invoke dgit, use --dgit= so that subprocesses use our
+    dgit rather than system one.
+  * Add a test for dgit rpush.
+
+  Major new feature, currently stalled awaiting server infrastructure:
+  * dgit-repos-server: New program for receiving signed-tag-based
+    pushes.  Corresponding support in dgit itself, but not currently
+    used by default for any distro.
+  * Bring forward push of the version tag ref so it happens alongside
+    the push of the suite branch ref.
+  * New git-check and git-create methods "true" which are no-ops.
+  * test-dummy-drs `distro': for testing dgit and dgit-repos-server.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Tue, 19 Aug 2014 11:24:02 +0100
+
 dgit (0.21) unstable; urgency=medium
 
   Bugfixes relating to unclean trees: