chiark / gitweb /
dgit: Set up a merge driver for debian/changelog. Closes:#769291.
[dgit.git] / debian / changelog
index 6629b0b57491ae9fc0608b73956ac6895205e800..9e8f572946ace82064a3249205c11dada4a009ca 100644 (file)
@@ -2,6 +2,7 @@ dgit (0.23~) unstable; urgency=low
 
   * Check for new dgit git service on dgit-git.debian.net (ie
     gideon.debian.org), with transition plan based on diversion feature.
+    Closes:#720172.
 
   * New handling for .pc directory: dgit history now no longer contains
     .pc at all.  It is deleted whenever we find it.  (When doing quilt
@@ -19,7 +20,7 @@ dgit (0.23~) unstable; urgency=low
 
   * Add :..; prefix to ssh remote commands, for the benefit of future
     forced command wrappers.  Implicitly, this defines a new ssh-based
-    command protocol.
+    command protocol.  Closes:#720174, #720175.
 
   * dgit-repos-server: Handle ' ' in SSH_ORIGINAL_COMMAND (which some
     git versions send, sigh).
@@ -35,6 +36,69 @@ dgit (0.23~) unstable; urgency=low
     al.  Client users probably don't want this stuff.  Also, it provides a
     convenient way to publish the dependencies.
 
+  * When generating quilt patches, try to linearise the git history into a
+    series of individual new patches for debian/patches.  Closes:#770710.
+
+  * Better documentation for quilt series handling.
+
+  * Strip `-b <branch>' from contents of Vcs-Git header, when setting up
+    the vcs-git remote.  Closes:#759374.
+
+  * Do not offer wget as an alternative dependency to curl.  We always
+    unconditionally invoke curl and have no code to use wget.
+    Closes:#760805.
+
+  * Complain about lack of cuddled values for value-taking single-letter
+    options, rather than thinking the user meat an empty value.
+    Closes:#763332.
+
+  * Reject (rather than ignoring) further options merged witht -wn, -wg,
+    -wd.
+
+  * Document in manpage under `dgit push' that it is best to build with
+    dgit too.  Closes:#763333.
+
+  * When receiving a push with dgit-repos-server, update the server's
+    refs/heads/master if we are pushing to what the distro regards as a
+    relevant branch, and the push would ff master.  Closes:#728209.
+
+  * Fix inaccurate error message when archive's git hash is not an
+    ancestor of git repo's git hash.
+
+  * Use ftpmasterapi archive query method.
+    (Closes:#727702.  Also partly obsoletes #768470.)
+
+  * Turn all perl warnings into errors using $SIG{__WARN__}.
+
+  * Show git config queries only with debuglevel 3 (-DDD) and higher.
+
+  * Fix an undef reference in error message processing when quilt
+    fixup linearisation fails.
+
+  * Quilt linearisation with .pc removal passes -f to git-rm.  (Otherwise
+    we may find that .pc/applied_patches prevents the commit.)
+
+  * Detect and bomb out on vendor-specific `3.0 (quilt)' patch series.
+
+  * Provide example workflow for dgit rpush.  Closes:#763334.
+    (Also part of the fix for #768470.)
+
+  * Document that dgit repos are cloneable with git, in dgit(1)
+    section MODEL.  [Andreas Barth.]  Closes:#768470.
+
+  * --clean=git and --clean=none cause dgit to pass -nc to
+    dpkg-buildpackage, suppressing calls to the package's clean target.
+    Also, expand the documentation in this area slightly.  Closes:#768590.
+
+  * Manpages: Break out dgit(7) from dgit(1).
+  * Manpages: Other clarifications and improvements.
+  * Change realpath dependency to `coreutils (>= 8.23-1~) | realpath'
+    (Closes:#786955.)
+  * For non-Debian distros, debiantag() uses distro name a la DEP-14.
+  * dgit: Be more careful about tag updates during fetch: only update
+    tags referring to uploads to distro we are trying to fetch from.
+  * dgit: Set up a merge driver for debian/changelog.  Closes:#769291.
+
  --
 
 dgit (0.22.1) unstable; urgency=high