chiark / gitweb /
Move defaulting out of archive_query into individual methods and the actual default...
[dgit.git] / debian / changelog
index 4e461967dfaee3d25ac3be348a5e864f1ed3c6e0..96f829ad249a48bff26de01eb3420ca97fb43f2d 100644 (file)
@@ -1,4 +1,29 @@
-dgit (0.22~experimental1) experimental; urgency=low
+dgit (0.23~) unstable; urgency=low
+
+  * New handling for .pc directory: dgit history now no longer contains
+    .pc at all.  It is deleted whenever we find it.  (When doing quilt
+    fixup, we recreate a suitable .pc in a temporary directory so that we
+    can do dpkg-source --comit.)  Closes:#764606.  INCOMPATIBLE CHANGE -
+    older versions of dgit will have trouble with these git histories.
+
+  * Replace many calls to stat with new wrapper stat_exists; improves
+    error handling and simplifies the code.
+
+  * Distro access configuration handling changes (should not be noticeable
+    to most users).
+
+ --
+
+dgit (0.22.1) unstable; urgency=high
+
+  * Use Dpkg::Version::version_compare everywhere, not
+    Dpkg::Version::version_compare_string.  The latter is entirely wrong,
+    meaning that dgit would get many version comparisons wrong.
+    Closes:#768038.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Tue, 04 Nov 2014 12:46:40 +0000
+
+dgit (0.22) unstable; urgency=medium
 
   Bugfixes:
   * Clone removes destination directory on error.  Closes:#736153.
@@ -10,10 +35,18 @@ dgit (0.22~experimental1) experimental; urgency=low
     Closes:#752602.
   * Check hashes of files ourselves rather than running dget to
     re-retreive the .dsc.
+  * Check SHA-256 of .dsc against hash from archive_query (ie projectb)
+    rather than letting dpkg-source do a signature verification.
+    Closes:#737619.  Closes:#737625.
+  * Treat .dsc as bytes, just like everything else, rather than letting
+    HTTP::Message convert it to a Perl unicode string which the rest of
+    the program mishandles.  Closes:#738536.
 
   Minor improvements:
   * Include canonicalised suite name in signed tag message.
   * Mention cross-version dgit rpush incompatibility in manpage.
+  * Check for rpush protocol version incompatibility and crash early
+    if incompatible.
   * New script tests/using-intree for running tests on the source tree.
   * Do not spew diff output to terminal (by default).  Print sensible
     message instead.  Closes:#736526.
@@ -21,6 +54,23 @@ dgit (0.22~experimental1) experimental; urgency=low
   * Document that dgit rpush needs gnupg and your public key on the build
     host.  Closes:#736529.
   * Fix a manpage reference to `--dget=' where `--dgit=' was intended.
+  * Provide t-archive-process-incoming and t-archive-query subroutines for
+    regression test scripts to use.
+  * Print better message for unknown operations.
+  * Provide `dgit clean'.  Closes:#736527.
+  * When cloning, set up a remote `vcs-git' from the package's Vcs-Git
+    (and put an appropriate caveat in the manpage).  Closes:#740687.
+    Closes:#740721.
+  * Improve error message for .dsc having already been signed (iff
+    using libdpkg-perl 1.17.x).  Closes:#731635.
+  * Improve error message for .dsc parsing failures more generally.
+  * Better reporting of child exit statuses (esp. deaths due to signals).
+  * In rpush, on protocol error talking to build host, check if the
+    subprocess died and report differently if so.  Closes:#736528.
+  * Fixed a manpage typo.
+  * When tests invoke dgit, use --dgit= so that subprocesses use our
+    dgit rather than system one.
+  * Add a test for dgit rpush.
 
   Major new feature, currently stalled awaiting server infrastructure:
   * dgit-repos-server: New program for receiving signed-tag-based
@@ -31,7 +81,7 @@ dgit (0.22~experimental1) experimental; urgency=low
   * New git-check and git-create methods "true" which are no-ops.
   * test-dummy-drs `distro': for testing dgit and dgit-repos-server.
 
- --
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Tue, 19 Aug 2014 11:24:02 +0100
 
 dgit (0.21) unstable; urgency=medium