chiark / gitweb /
dgit-repos-policy-debian: Better error handling
[dgit.git] / debian / changelog
index 93ce3d4d4f369de6e11a875303fd166a2982c030..7543f58ea2235423458da2c1571e0e81791a882c 100644 (file)
@@ -7,6 +7,28 @@ dgit (1.5~~) unstable; urgency=medium
     has been changed recently and now this default setting is very awkward
     to change for the dgit user.
 
     has been changed recently and now this default setting is very awkward
     to change for the dgit user.
 
+  New checks and improved behaviours:
+  * When running dpkg-buildpackage, cope if user specified -g or -G.
+  * dgit sbuild: check that the set of .changes files found is as we
+    expect, before calling mergechanges.
+  * dgit sbuild: Rename the used-up .changes files to `.inmulti' to
+    avoid accidental use of the wrong one (by software, or by users).
+  * dgit sbuild: Check that the binary .changes file doesn't contain a
+    .dsc.
+  * Introduce --rm-old-changes to delete previous builds' changes files.
+  * Remove any pre-existing _source.changes file before building source,
+    as a safety check.
+  * No longer tolerate a multitude of .changes files when doing push.
+    Instead, insist on a single one.
+  * dgit sbuild no longer deletes extranious .changes files; instead
+    we rely on --rm-old-changes, or failing that, fail early.
+
+  Infrastructure:
+  * Better error handling in dgit-repos-policy-debian.
+
+  Documentation:
+  * Document the dgit-distro.DISTRO.quilt-mode config setting.
+
   Bugfixes:
   * When cleaning up after failed clone, stat the to-be-cleaned-up
     directory before running rmtree on it.  Closes:#796773.
   Bugfixes:
   * When cleaning up after failed clone, stat the to-be-cleaned-up
     directory before running rmtree on it.  Closes:#796773.
@@ -31,6 +53,9 @@ dgit (1.5~~) unstable; urgency=medium
   * Increase sqlite_busy_timeout in debpolicy-dbretry, because
     zealot is very slow and we need to give the other processes time
     to rollback and release the lock.
   * Increase sqlite_busy_timeout in debpolicy-dbretry, because
     zealot is very slow and we need to give the other processes time
     to rollback and release the lock.
+  * Test quilt single-debian-patch.
+  * Provide `tartree-edit gitfetchinfo' etc. to help with comparing
+    different test case git working tree tarballs.
 
  --
 
 
  --