chiark / gitweb /
Fix the rules clean target to remove test results and output.
[dgit.git] / debian / changelog
index e0764f5523b9cb9dcd9236277920cc23bee22df1..63fb0debadecbdcb3034fc43846694fe34ebf164 100644 (file)
@@ -1,44 +1,95 @@
-dgit (0.23~) unstable; urgency=low
+dgit (0.30) unstable; urgency=high
 
-  * Check for new dgit git service on dgit-git.debian.net (ie
-    gideon.debian.org), with transition plan based on diversion feature.
+  INCOMPATIBLE CHANGES:
 
-  * New handling for .pc directory: dgit history now no longer contains
-    .pc at all.  It is deleted whenever we find it.  (When doing quilt
-    fixup, we recreate a suitable .pc in a temporary directory so that we
-    can do dpkg-source --comit.)  Closes:#764606.  INCOMPATIBLE CHANGE -
-    older versions of dgit will have trouble with these git histories.
+  * Client uses new infrastructure:
+    - Check for new dgit git service on dgit-git.debian.net (ie
+      gideon.debian.org), with transition plan based on diversion feature.
+      Closes:#720172.
+    - Old versions of dgit will stop working when the server-side handle is
+      pulled.
 
-  * Replace many calls to stat with new wrapper stat_exists; improves
-    error handling and simplifies the code.
+  * dgit git trees no longer contain .pc for format `3.0 (quilt)' source
+    packages.  Closes:#764606.
+    - It is deleted whenever we find it.
+    - Older versions of dgit will choke on trees without .pc.
+    - (When doing quilt fixup, we recreate a suitable .pc in a temporary
+      directory so that we can do dpkg-source --comit.)
 
-  * Fix handling of rmadison-based and gitless distros (e.g., Ubuntu).
+  * All users are urged to upgrade ASAP.
 
-  * Distro access configuration handling changes (should not be noticeable
-    to most users).
+  Other significant improvements:
 
-  * Add :..; prefix to ssh remote commands, for the benefit of future
-    forced command wrappers.  Implicitly, this defines a new ssh-based
-    command protocol.
+  * When generating quilt patches, try to linearise the git history into a
+    series of individual new patches for debian/patches.  Closes:#770710.
 
-  * dgit-repos-server: Handle ' ' in SSH_ORIGINAL_COMMAND (which some
-    git versions send, sigh).
+  * When receiving a push with dgit-repos-server, update the server's
+    refs/heads/master if we are pushing to what the distro regards as a
+    relevant branch, and the push would ff master.  Closes:#728209.
 
-  * New dgit-ssh-dispatch infrastructure script for use on dgit repos
-    server as part of ssh forced command.
+  * For non-Debian distros, distro version release tags contain distro
+    name a la DEP-14 (rather than hardcoding `debian/').
 
-  * Test suite restructuring to support new tests.
+  * Set up a merge driver for debian/changelog.  Closes:#769291.
+
+  * --clean=git and --clean=none cause dgit to pass -nc to
+    dpkg-buildpackage, suppressing calls to the package's clean target.
+    Also, expand the documentation in this area slightly.  Closes:#768590.
+
+  Minor improvements:
+
+  * Reduce some noise output and improve the clarity of some messages.
+  * Be more careful about tag updates during fetch: only update tags
+    referring to uploads to distro we are trying to fetch from.
+  * Change realpath dependency to `coreutils (>= 8.23-1~) | realpath'
+    (Closes:#786955.)
+
+  Bugfixes:
 
+  * Fix handling of rmadison-based and gitless distros (e.g., Ubuntu).
   * Add missing `gpgv' to test dependencies in debian/tests/control.
+  * Strip `-b <branch>' from contents of Vcs-Git header, when setting up
+    the vcs-git remote.  Closes:#759374.
+  * Do not offer wget as an alternative dependency to curl.  We always
+    unconditionally invoke curl and have no code to use wget.
+    Closes:#760805.
+  * Complain about lack of cuddled values for value-taking single-letter
+    options, rather than thinking the user meat an empty value.
+    Closes:#763332.
+  * Reject (rather than ignoring) further options merged witth -wn, -wg,
+    -wd.
+  * Fix inaccurate error message when archive's git hash is not an
+    ancestor of git repo's git hash.
+  * Detect and bomb out on vendor-specific `3.0 (quilt)' patch series.
+  * Fix the rules clean target to remove test results and output.
+
+  Documentation improvements:
+
+  * Break out dgit(7) from dgit(1).
+  * Provide example workflow for dgit rpush.  Closes:#763334.
+    (Also part of the fix for #768470.)
+  * Document that dgit repos are cloneable with git, in dgit(1)
+    section MODEL.  [Andreas Barth.]  Closes:#768470.
+  * Better documentation for quilt series handling.
+  * Document under `dgit push' that it is best to build with dgit too.
+    Closes:#763333.
+  * Other minor clarifications and improvements.
+
+  Behind-the-scenes work:
 
+  * Use ftpmasterapi archive query method.
+    (Closes:#727702.  Also partly obsoletes #768470.)
   * New dgit-infrastructure binary package containing dgit-repos-server et
     al.  Client users probably don't want this stuff.  Also, it provides a
     convenient way to publish the dependencies.
-
-  * When generating quilt patches, try to linearise the git history into a
-    series of individual new patches for debian/patches.  Closes:#720177.
-
-  * Better documentation for quilt series handling.
+  * Many many bugfixes to the server side (dpkg-repos-server et al.).
+  * Add :..; prefix to ssh remote commands, for the benefit of future
+    forced command wrappers.  Implicitly, this defines a new ssh-based
+    command protocol.  Closes:#720174, #720175.
+  * Distro access configuration handling changes (should not be noticeable
+    to most users).
+  * In places, significant restructuring or tidying up.
+  * Turn all perl warnings into errors using $SIG{__WARN__}.
 
  --