chiark / gitweb /
Copyright: Add notices to some more of the (larger) files
[dgit.git] / debian / changelog
index 7543f58ea2235423458da2c1571e0e81791a882c..5d337818390cbe52b4c135a2f3e59282a153773c 100644 (file)
@@ -7,10 +7,15 @@ dgit (1.5~~) unstable; urgency=medium
     has been changed recently and now this default setting is very awkward
     to change for the dgit user.
 
+  Major new feature:
+  * --quilt=gbp, --quilt=dpm, --quilt=unpacked: Introduce facility for
+    split view (dgit/mainiainer view), to improve compatibility with some
+    other workflow tools.
+
   New checks and improved behaviours:
   * When running dpkg-buildpackage, cope if user specified -g or -G.
   * dgit sbuild: check that the set of .changes files found is as we
-    expect, before calling mergechanges.
+    expect, before calling mergechanges.  Re:#800060.
   * dgit sbuild: Rename the used-up .changes files to `.inmulti' to
     avoid accidental use of the wrong one (by software, or by users).
   * dgit sbuild: Check that the binary .changes file doesn't contain a
@@ -19,15 +24,45 @@ dgit (1.5~~) unstable; urgency=medium
   * Remove any pre-existing _source.changes file before building source,
     as a safety check.
   * No longer tolerate a multitude of .changes files when doing push.
-    Instead, insist on a single one.
+    Instead, insist on a single one.  Closes:#800110.
   * dgit sbuild no longer deletes extranious .changes files; instead
     we rely on --rm-old-changes, or failing that, fail early.
+  * When doing quilt linearisation, treat upstream .gitignores not
+    in the toplevel the same way we treat ones in the toplevel.
+  * When automatically generating quilt patch, honour GIT_COMMITTER_DATE
+    for filename creation (makes filename deterministic in test suite).
+  * New --overwrite option, replaces need to for user to use
+    git merge -s ours.  Closes:#838718.
+  * When generating quilt patches from git commits, make patches that
+    look quite like git-format-patch output (rather than strange things
+    based on an obselete interpretation of DEP-3).
+  * When generating quilt patches from git commits, honour (and strip)
+    any Gbp-Pq headers (that we understand).
+  * Several dgit-generated commits now have slightly better annotations
+    from dgit about what it was doing.
+  * Make --quilt=gbp the default for dgit gbp-build.
+  * New tag format (for dgit view) archive/debian/VERSION.
+  * Before committing to push, check that .dsc and .changes correspond.
+    Closes:#800060.
+  * Better error message if non-split-brain patch stack no longer
+    applies (due to new upstream version, or user messing with it).
+    Closes:#833025.
+  * Better error message if HEAD contains changes unrepresentable
+    by `3.0 (quilt)'.  Closes:#834618.
+  * Much better error message when HEAD and .dsc do not match.
+    Closes:#809516.
 
   Infrastructure:
   * Better error handling in dgit-repos-policy-debian.
+  * dgit-repos-policy-debian.: fix git-cat-file-handling with multiple
+    taints in db (!).
 
   Documentation:
   * Document the dgit-distro.DISTRO.quilt-mode config setting.
+  * Clarify the --clean= options' documentation.  Closes:#800054.
+  * Discourage use of the --PROGRAM:OPTION escape hatch.  (Apropos
+    of various bug reports including #800060 and #833025.)
+  * Document the expected form of HEAD for each --quilt= mode.
 
   Bugfixes:
   * When cleaning up after failed clone, stat the to-be-cleaned-up
@@ -40,6 +75,30 @@ dgit (1.5~~) unstable; urgency=medium
     messages.  Closes:#800078.
   * Pass --ch:* and -v options to dpkg-buildpackage when building
     source.  Fixes bad Perl poetry syntax.  Closes:#829121.
+  * When synthesing a commit from a .dsc from the archive, stop
+    internal git reset from printing a confusing message about HEAD.
+  * Turn off git gc in the private working areas.
+  * Do not fail to do some important quilt processing in some
+    --quilt modes.
+  * Fix two calls to chdir without proper error checking.
+  * Fix a couple of bugs in error reporting.
+  * Fix up .orig detection to be less trustful of (ambiguous) filenames.
+  * Fix up .orig detection to correctly allow exactly the right
+    .orig-comp components accorging to dpkg-source(1).
+  * Fix up .orig detection to handle .asc's (and other signatures)
+    of .orig components the same way as their tarballs.
+  * Tidy up refs/dgit-fetch/ after dgit fetch (if successful).
+  * Fix handling of in-archive copies.
+  * Don't break if user has push.followTags=true.  Closes:#827878.
+  * Arrange for the special dgit remote to be skipped by git fetch --all
+    etc.  And no longer configure a fetch spec, since it won't work
+    anyway.  Closes:#827892.
+  * Allow local git config options to override user-global ones,
+    as is proper.  Closes:#835858.
+  * Get sense of failed clone failed cleanup error reporting check
+    correct.  Closes:#796773.
+  * When generating patch filenames from titles, first transliterate
+    them (lossily) to ascii.  Closes:#834807.
 
   Test suite:
   * When sbuild fails, do not crash due to sed not finding the log
@@ -56,6 +115,9 @@ dgit (1.5~~) unstable; urgency=medium
   * Test quilt single-debian-patch.
   * Provide `tartree-edit gitfetchinfo' etc. to help with comparing
     different test case git working tree tarballs.
+  * Test dgit-repos-policy-debian with multiple (identical, as it happens)
+    existing taints.
+  * Provide better log output for certain failures.
 
  --