chiark / gitweb /
Update changelog for in-archive copies
[dgit.git] / debian / changelog
index 5d9e8cb064bdf2222de78e7fa4a930fd6c64ee88..4e38d1cdca96c352927b8705114ecd43a3049f8d 100644 (file)
@@ -7,15 +7,46 @@ dgit (1.5~~) unstable; urgency=medium
     has been changed recently and now this default setting is very awkward
     to change for the dgit user.
 
+  Major new feature:
+  * --quilt=gbp, --quilt=dpm, --quilt=unpacked: Introduce facility for
+    split view (dgit/mainiainer view), to improve compatibility with some
+    other workflow tools.
+
   New checks and improved behaviours:
   * When running dpkg-buildpackage, cope if user specified -g or -G.
   * dgit sbuild: check that the set of .changes files found is as we
     expect, before calling mergechanges.
   * dgit sbuild: Rename the used-up .changes files to `.inmulti' to
-    avoid accidental  use of the wrong one (by software, or by users).
+    avoid accidental use of the wrong one (by software, or by users).
   * dgit sbuild: Check that the binary .changes file doesn't contain a
     .dsc.
   * Introduce --rm-old-changes to delete previous builds' changes files.
+  * Remove any pre-existing _source.changes file before building source,
+    as a safety check.
+  * No longer tolerate a multitude of .changes files when doing push.
+    Instead, insist on a single one.
+  * dgit sbuild no longer deletes extranious .changes files; instead
+    we rely on --rm-old-changes, or failing that, fail early.
+  * When doing quilt linearisation, treat upstream .gitignores not
+    in the toplevel the same way we treat ones in the toplevel.
+  * When automatically generating quilt patch, honour GIT_COMMITTER_DATE
+    for filename creation (makes filename deterministic in test suite).
+  * New --overwrite option, replaces need to for user to use
+    git merge -s ours.  Closes:#838718.
+  * When generating quilt patches from git commits, make patches that
+    look quite like git-format-patch output (rather than strange things
+    based on an obselete interpretation of DEP-3).
+  * When generating quilt patches from git commits, honour (and strip)
+    any Gbp-Pq headers (that we understand).
+  * Several dgit-generated commits now have slightly better annotations
+    from dgit about what it was doing.
+  * Make --quilt=gbp the default for dgit gbp-build.
+  * New tag format (for dgit view) archive/debian/VERSION.
+
+  Infrastructure:
+  * Better error handling in dgit-repos-policy-debian.
+  * dgit-repos-policy-debian.: fix git-cat-file-handling with multiple
+    taints in db (!).
 
   Documentation:
   * Document the dgit-distro.DISTRO.quilt-mode config setting.
@@ -31,6 +62,18 @@ dgit (1.5~~) unstable; urgency=medium
     messages.  Closes:#800078.
   * Pass --ch:* and -v options to dpkg-buildpackage when building
     source.  Fixes bad Perl poetry syntax.  Closes:#829121.
+  * When synthesing a commit from a .dsc from the archive, stop
+    internal git reset from printing a confusing message about HEAD.
+  * Turn off git gc in the private working areas.
+  * Do not fail to do some important quilt processing in some
+    --quilt modes.
+  * Fix two calls to chdir without proper error checking.
+  * Fix a couple of bugs in error reporting.
+  * Fix up .orig detection to be less trustful of (ambiguous) filenames.
+  * Fix up .orig detection to correctly allow exactly the right
+    .orig-comp components accorging to dpkg-source(1).
+  * Fix up .orig detection to handle .asc's (and other signatures)
+    of .orig components the same way as their tarballs.
 
   Test suite:
   * When sbuild fails, do not crash due to sed not finding the log
@@ -45,6 +88,12 @@ dgit (1.5~~) unstable; urgency=medium
     zealot is very slow and we need to give the other processes time
     to rollback and release the lock.
   * Test quilt single-debian-patch.
+  * Provide `tartree-edit gitfetchinfo' etc. to help with comparing
+    different test case git working tree tarballs.
+  * Test dgit-repos-policy-debian with multiple (identical, as it happens)
+    existing taints.
+  * Provide better log output for certain failures.
+  * Fix handling of in-archive copies.
 
  --