chiark / gitweb /
When running dpkg-buildpackage, cope if user specified -g or -G.
[dgit.git] / debian / changelog
index e09cfbbfdbe3b2d09b3647d035ef7734e7b985d8..49a72bbc5fc08e10c134b313f7ca10c49e331d52 100644 (file)
@@ -1,5 +1,52 @@
-dgit (1.4~~) UNRELEASED; urgency=low
+dgit (1.5~~) unstable; urgency=medium
+
+  Incompatible change:
+  * dgit sbuild does not pass -A to sbuild.  Consequently the default
+    build is now simply sbuild's default.  With older sbuilds it was
+    possible to override dgit's -A by passing another option.  But this
+    has been changed recently and now this default setting is very awkward
+    to change for the dgit user.
+
+  New checks and improved behaviours:
+  * When running dpkg-buildpackage, cope if user specified -g or -G.
+  * dgit sbuild: check that the set of .changes files found is as we
+    expect, before calling mergechanges.
+  * dgit sbuild: Rename the used-up .changes files to `.inmulti' to
+    avoid accidental  use of the wrong one (by software, or by users).
+  * dgit sbuild: Check that the binary .changes file doesn't contain a
+    .dsc.
 
+  Bugfixes:
+  * When cleaning up after failed clone, stat the to-be-cleaned-up
+    directory before running rmtree on it.  Closes:#796773.
+  * Do not call "warn" on failure of cleanup handler in END block
+    (since warn has been made fatal and aborts the cleanup chain).
+  * Print better error message (with `fail' rather than `die') if
+    `dgit clone' cannot create the destination directory.
+  * Properly substitute $changesfile in one of the `You can retry'
+    messages.  Closes:#800078.
+  * Pass --ch:* and -v options to dpkg-buildpackage when building
+    source.  Fixes bad Perl poetry syntax.  Closes:#829121.
+
+  Test suite:
+  * When sbuild fails, do not crash due to sed not finding the log
+    file.  Instead, simply tolerate the absence of the log file.
+  * Put --no-arch-all in build-modes-sbuild act, not only its real_act.
+    Cosmetic change only.
+  * Set GIT_COMMITTER_DATE and GIT_AUTHOR_DATE and increment them
+    explicitly in drs-push-rejects test.  This avoids date dependencies
+    which can cause that test to fail on fast computers.
+  * Remove some spurios .debs from the example_1.0.tar.
+  * Increase sqlite_busy_timeout in debpolicy-dbretry, because
+    zealot is very slow and we need to give the other processes time
+    to rollback and release the lock.
+  * Test quilt single-debian-patch.
+
+ --
+
+dgit (1.4) unstable; urgency=high
+
+  Bugfixes:
   * Unbreak --dry-run (`exiting subroutine via next', broken in
     ac221d67, bug released in 0.22).
   * When running git-add in commit-quilty-patch, properly escape
@@ -8,20 +55,29 @@ dgit (1.4~~) UNRELEASED; urgency=low
     so as to avoid being broken by any .gitignore, etc.
   * When quilt linearisation fails, print the right information in
     the error message.  (This has been broken forever.)
-  * In dgit(7), discuss binaries and documentation present in upstream but
-    removed by rules clean.
-  * Detect and reject git trees containing debian/source/local-options
-    or debian/source/local-patch-header.
-  * In --dry-run mode, _do_ actually run dpkg-source --commit so that we
-    actually do construct the quilt fixup commit; instead, honour
-    --dry-run by avoiding pulling it back to your HEAD.
   * Cope properly with `3.0 (quilt)' with single-debian-patch.
     Closes:#796016.  (Still does not work with wheezy's dpkg-source, so
     no test case yet.)
   * With dgit sbuild, pass our -d before the user's arguments, so that
     the user can override it.  Closes:#796019.
 
- --
+  New checks and improved behaviours:
+  * Detect and reject git trees containing debian/source/local-options
+    or debian/source/local-patch-header.
+  * In --dry-run mode, _do_ actually run dpkg-source --commit so that we
+    actually do construct the quilt fixup commit; instead, honour
+    --dry-run by avoiding pulling it back to your HEAD.
+  * quilt-fixup checks that the git tree is clean, as for build-prep.
+
+  Documentation:
+  * In dgit(7), discuss binaries and documentation present in upstream but
+    removed by rules clean.
+
+  Test suite:
+  * Run quilt-fixup with -wgf in distropatches-reject,
+    so that we don't need build-depends.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Sat, 22 Aug 2015 15:31:02 +0100
 
 dgit (1.3) unstable; urgency=high