chiark / gitweb /
Finalise 0.30, really
[dgit.git] / debian / changelog
index 77900c3166b279136862ef87907d8eb4062f8e8a..1bae402ab44f25460915d0f7f77d16556f362ee9 100644 (file)
@@ -1,3 +1,320 @@
+dgit (0.30) unstable; urgency=high
+
+  INCOMPATIBLE CHANGES:
+
+  * Client uses new infrastructure:
+    - Check for new dgit git service on dgit-git.debian.net (ie
+      gideon.debian.org), with transition plan based on diversion feature.
+      Closes:#720172.
+    - Old versions of dgit will stop working when the server-side handle is
+      pulled.
+
+  * dgit git trees no longer contain .pc for format `3.0 (quilt)' source
+    packages.  Closes:#764606.
+    - It is deleted whenever we find it.
+    - Older versions of dgit will choke on trees without .pc.
+    - (When doing quilt fixup, we recreate a suitable .pc in a temporary
+      directory so that we can do dpkg-source --comit.)
+
+  * All users are urged to upgrade ASAP.
+
+  Other significant improvements:
+
+  * When generating quilt patches, try to linearise the git history into a
+    series of individual new patches for debian/patches.  Closes:#770710.
+
+  * When receiving a push with dgit-repos-server, update the server's
+    refs/heads/master if we are pushing to what the distro regards as a
+    relevant branch, and the push would ff master.  Closes:#728209.
+
+  * For non-Debian distros, distro version release tags contain distro
+    name a la DEP-14 (rather than hardcoding `debian/').
+
+  * Set up a merge driver for debian/changelog.  Closes:#769291.
+
+  * --clean=git and --clean=none cause dgit to pass -nc to
+    dpkg-buildpackage, suppressing calls to the package's clean target.
+    Also, expand the documentation in this area slightly.  Closes:#768590.
+
+  * Provide --clean=git-ff (aka -wgf), which is useful for dgit itself (!)
+
+  Minor improvements:
+
+  * Reduce some noise output and improve the clarity of some messages.
+  * Be more careful about tag updates during fetch: only update tags
+    referring to uploads to distro we are trying to fetch from.
+  * Change realpath dependency to `coreutils (>= 8.23-1~) | realpath'
+    (Closes:#786955.)
+
+  Bugfixes:
+
+  * Fix handling of rmadison-based and gitless distros (e.g., Ubuntu).
+  * Add missing `gpgv' to test dependencies in debian/tests/control.
+  * Strip `-b <branch>' from contents of Vcs-Git header, when setting up
+    the vcs-git remote.  Closes:#759374.
+  * Do not offer wget as an alternative dependency to curl.  We always
+    unconditionally invoke curl and have no code to use wget.
+    Closes:#760805.
+  * Complain about lack of cuddled values for value-taking single-letter
+    options, rather than thinking the user meat an empty value.
+    Closes:#763332.
+  * Reject (rather than ignoring) further options merged witth -wn, -wg,
+    -wd.
+  * Fix inaccurate error message when archive's git hash is not an
+    ancestor of git repo's git hash.
+  * Detect and bomb out on vendor-specific `3.0 (quilt)' patch series.
+  * Fix the rules clean target to remove test results and output.
+
+  Documentation improvements:
+
+  * Break out dgit(7) from dgit(1).
+  * Provide example workflow for dgit rpush.  Closes:#763334.
+    (Also part of the fix for #768470.)
+  * Document that dgit repos are cloneable with git, in dgit(1)
+    section MODEL.  [Andreas Barth.]  Closes:#768470.
+  * Better documentation for quilt series handling.
+  * Document under `dgit push' that it is best to build with dgit too.
+    Closes:#763333.
+  * Other minor clarifications and improvements.
+
+  Behind-the-scenes work:
+
+  * Use ftpmasterapi archive query method.
+    (Closes:#727702.  Also partly obsoletes #768470.)
+  * New dgit-infrastructure binary package containing dgit-repos-server et
+    al.  Client users probably don't want this stuff.  Also, it provides a
+    convenient way to publish the dependencies.
+  * Many many bugfixes to the server side (dpkg-repos-server et al.).
+  * Add :..; prefix to ssh remote commands, for the benefit of future
+    forced command wrappers.  Implicitly, this defines a new ssh-based
+    command protocol.  Closes:#720174, #720175.
+  * Distro access configuration handling changes (should not be noticeable
+    to most users).
+  * In places, significant restructuring or tidying up.
+  * Turn all perl warnings into errors using $SIG{__WARN__}.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Sun, 05 Jul 2015 01:34:55 +0100
+
+dgit (0.22.1) unstable; urgency=high
+
+  * Use Dpkg::Version::version_compare everywhere, not
+    Dpkg::Version::version_compare_string.  The latter is entirely wrong,
+    meaning that dgit would get many version comparisons wrong.
+    Closes:#768038.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Tue, 04 Nov 2014 12:46:40 +0000
+
+dgit (0.22) unstable; urgency=medium
+
+  Bugfixes:
+  * Clone removes destination directory on error.  Closes:#736153.
+  * Work with wheezy-backports (and keep squeeze-backports working too).
+    Closes:#736524.
+  * Work in read-only no-git-history mode with Ubuntu.  You still have
+    to pass -dubuntu.  Closes:#751781.
+  * Use mirror.ftp-master.debian.org DNS alias rather than coccia.
+    Closes:#752602.
+  * Check hashes of files ourselves rather than running dget to
+    re-retreive the .dsc.
+  * Check SHA-256 of .dsc against hash from archive_query (ie projectb)
+    rather than letting dpkg-source do a signature verification.
+    Closes:#737619.  Closes:#737625.
+  * Treat .dsc as bytes, just like everything else, rather than letting
+    HTTP::Message convert it to a Perl unicode string which the rest of
+    the program mishandles.  Closes:#738536.
+
+  Minor improvements:
+  * Include canonicalised suite name in signed tag message.
+  * Mention cross-version dgit rpush incompatibility in manpage.
+  * Check for rpush protocol version incompatibility and crash early
+    if incompatible.
+  * New script tests/using-intree for running tests on the source tree.
+  * Do not spew diff output to terminal (by default).  Print sensible
+    message instead.  Closes:#736526.
+  * Print better message for lack of configuration settings.
+  * Document that dgit rpush needs gnupg and your public key on the build
+    host.  Closes:#736529.
+  * Fix a manpage reference to `--dget=' where `--dgit=' was intended.
+  * Provide t-archive-process-incoming and t-archive-query subroutines for
+    regression test scripts to use.
+  * Print better message for unknown operations.
+  * Provide `dgit clean'.  Closes:#736527.
+  * When cloning, set up a remote `vcs-git' from the package's Vcs-Git
+    (and put an appropriate caveat in the manpage).  Closes:#740687.
+    Closes:#740721.
+  * Improve error message for .dsc having already been signed (iff
+    using libdpkg-perl 1.17.x).  Closes:#731635.
+  * Improve error message for .dsc parsing failures more generally.
+  * Better reporting of child exit statuses (esp. deaths due to signals).
+  * In rpush, on protocol error talking to build host, check if the
+    subprocess died and report differently if so.  Closes:#736528.
+  * Fixed a manpage typo.
+  * When tests invoke dgit, use --dgit= so that subprocesses use our
+    dgit rather than system one.
+  * Add a test for dgit rpush.
+
+  Major new feature, currently stalled awaiting server infrastructure:
+  * dgit-repos-server: New program for receiving signed-tag-based
+    pushes.  Corresponding support in dgit itself, but not currently
+    used by default for any distro.
+  * Bring forward push of the version tag ref so it happens alongside
+    the push of the suite branch ref.
+  * New git-check and git-create methods "true" which are no-ops.
+  * test-dummy-drs `distro': for testing dgit and dgit-repos-server.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Tue, 19 Aug 2014 11:24:02 +0100
+
+dgit (0.21) unstable; urgency=medium
+
+  Bugfixes relating to unclean trees:
+  * Run a clean (of the specified type) before any build operation; do
+    this with `dpkg-buildpackage -T' clean if necessary, so -wd now works
+    with all the building methods.
+  * Refuse to do quilt fixup (explicitly requested, or as a result of
+    build) if the tree contains ignored files.  Closes:#731632.
+
+  Error message improvements:
+  * Use failedcmd to report errors when ssh psql fails.  Closes:#734281.
+  * failedcmd prints $us, not $_[0] - ie, dgit doesn't pretend,
+    in the error message, to be its child.
+  * Do not report the (irrelevant) $? when madison parsing fails.
+
+  Better workflow flexibility:
+  * Provide --build-products-dir option (and corresponding semantics
+    for -C) to specify where to find the files to upload.  Closes:#731633.
+
+  Support for Debian backports suites:
+  * New quirks infrastructure in configuration and internals,
+    for suites (or perhaps distros) which are a bit like others.
+  * Use correct default archive location.
+  * Compute "-v" option default value correctly.
+  * Closes:#733954.
+
+  Packaging improvement:
+  * Add `Testsuite: autopkgtest' to debian/control.  (This will only have
+    the right effect with recent enought dpkg; it will generate a harmless
+    warning with earlier versions of dpkg.)
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Sun, 19 Jan 2014 02:14:25 +0000
+
+dgit (0.20) unstable; urgency=high
+
+  * Use newest (not oldest) version currently in suite when calculating
+    what value to use for -v<version> by default.  Closes:#732781.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Sat, 21 Dec 2013 19:13:56 +0000
+
+dgit (0.19) unstable; urgency=low
+
+  Testing facilities:
+  * Provide "test-dummy" distro with "dummycat" access method.
+  * Provide a selection of autopkgtest (DEP-8) tests.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Wed, 27 Nov 2013 18:27:17 +0000
+
+dgit (0.18.2) unstable; urgency=high
+
+  Bump archive upload urgency to high.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Sun, 24 Nov 2013 17:42:57 +0000
+dgit (0.18.1) unstable; urgency=low
+
+  Bugfixes:
+  * sshpsql archive query method passes LANG=C.  Closes:#729788.
+  * Subcommand program or argument options containing hyphens work.
+    (Eg, --dpkg-buildpackage:blah was previously incorrectly rejected.)
+
+  Packaging fixes:
+  * Depend on dput.
+  * Depend on curl | wget, as dget needs one of those.  (The dput package,
+    which contains dget, doesn't require them because dput itself works
+    without.)
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Sun, 24 Nov 2013 17:36:03 +0000
+
+dgit (0.18) unstable; urgency=low
+
+  Major new feature:
+  * Remote push (dgit rpush), a la debsign -r.  Closes:#721185.
+
+  Improved behaviours:
+  * dgit build, by default, uses the archive to find out what the correct
+    -v<version> option is to pass to dpkg-genchanges.  Closes:#727200.
+  * Abolish the sshdakls method and replace it with sshpsql: that is, ssh
+    (to coccia, by default) and run sql commands on the ftpmaster
+    database.  This is faster and has fewer bugs but is vulnerable to db
+    schema changes.  Closes:#726955.  Closes:#720170.  Closes:#720176.
+  * When generating git tags, quote the (uncanonicalised) changelog's
+    Distribution field as the suite.
+  * Command execution reports from --dry-run go to stderr.
+
+  Other new features:
+  * Support --gpg=... to provide a replacement command for gpg.
+  * Support --ssh=... and --ssh:... to affect how we run ssh.
+
+  Bugfixes:
+  * When using sbuild, pass the arguments to mergechanges in the right
+    order so that we use the correct Description (the _source one,
+    not the one from sbuild which didn't get e.g. -v<version>).
+  * push actually takes an optional suite, like it says in the synopsis.
+    Closes:#727125.
+  * Fix dgit --damp-run sbuild to actually work.
+  * Fix the "shellquote" internal subroutine.  The bugs in it ought not to
+    have caused any real trouble in previous versions of dgit.
+
+  Documentation and message fixes:
+  * manpage: Clarify comments about orig tarballs.  Closes: #723605.
+  * manpage: Remove comment in BUGS about lack of policy docs
+    for Dgit field, which is specified now.  Closes:#720201.
+  * manpage: Make discussion of --existing-package less scary.  The
+    default archive access method no longer needs it.  Closes:#720171.
+  * Mention "git merge", not "git-merge", in helpful message.
+    Closes:#725632.
+
+  Internal and debugging improvements:
+  * Report chdir actions in debugging output.
+  * Improvements to implementation of --dry-run and --damp-run.
+  * Some code motion and cleanups.
+
+  Note: changelog entries for the following versions, which were uploaded
+  to Debian experimental, have been collapsed into this single entry:
+    0.18~experimental2 0.18~experimental1
+    0.17~experimental7 0.17~experimental6 0.17~experimental5
+    0.17~experimental4 0.17~experimental3 0.17~experimental2
+    0.17~experimental1
+    0.16~experimental3 0.16~experimental2 0.16~experimental1
+  We do describe here all the changes since 0.17.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Sat, 09 Nov 2013 10:12:13 +0000
+
+dgit (0.17) unstable; urgency=high
+
+  * Do not grobble around in .git/refs/; instead, use git-show-ref.
+    This avoids breaking when git makes packed refs.  Closes:728893.
+  * Clarify error message for missing refs/remotes/dgit/dgit/<suite>.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Thu, 07 Nov 2013 00:02:47 +0000
+
+dgit (0.16) unstable; urgency=high
+
+  * Format `(3.0) quilt' fixup does not mind extraneous other files
+    in the build tree (e.g., build products and logs).  Closes: #727053.
+  * Set autoflush on stdout, to get better ordering of debugging
+    etc. output when stdout is redirected.
+  * New --damp-run mode, for more convenient and fuller testing etc.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Tue, 22 Oct 2013 13:06:54 +0100
+
+dgit (0.15) unstable; urgency=low
+
+  * Better handling of packages pushed using dgit and stuck in NEW.
+    (And, use of `--new' is not needed with fetch.)  Closes: #722199.
+  * More comprehensive warnings in many cases of archive skew.
+  * Implement `dgit help' as well as `--help'.  Closes: #721661.
+  * Provide `dgit version' and `--version'.  Closes: #721654.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Thu, 12 Sep 2013 00:14:05 +0100
+
 dgit (0.14) unstable; urgency=low
 
   * Include package name in tag message.
 dgit (0.14) unstable; urgency=low
 
   * Include package name in tag message.
@@ -6,7 +323,7 @@ dgit (0.14) unstable; urgency=low
     These fields refer to the development branch, "master", on alioth,
     not to the dgit suite refs (which are not accessible to git clone).
 
     These fields refer to the development branch, "master", on alioth,
     not to the dgit suite refs (which are not accessible to git clone).
 
- --
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Sun, 01 Sep 2013 18:30:44 +0100
 
 dgit (0.13) unstable; urgency=low
 
 
 dgit (0.13) unstable; urgency=low