chiark / gitweb /
dgit.1: Clarify the --clean= options' documentation. Closes:#800054.
[dgit.git] / debian / changelog
index 7143fe7d5b222cbc6782efd41e20e36fa1e371fe..18e3e3e4f11ae072306b350f8683e945e4f735d9 100644 (file)
@@ -7,6 +7,11 @@ dgit (1.5~~) unstable; urgency=medium
     has been changed recently and now this default setting is very awkward
     to change for the dgit user.
 
+  Major new feature:
+  * --quilt=gbp, --quilt=dpm, --quilt=unpacked: Introduce facility for
+    split view (dgit/mainiainer view), to improve compatibility with some
+    other workflow tools.
+
   New checks and improved behaviours:
   * When running dpkg-buildpackage, cope if user specified -g or -G.
   * dgit sbuild: check that the set of .changes files found is as we
@@ -26,6 +31,17 @@ dgit (1.5~~) unstable; urgency=medium
     in the toplevel the same way we treat ones in the toplevel.
   * When automatically generating quilt patch, honour GIT_COMMITTER_DATE
     for filename creation (makes filename deterministic in test suite).
+  * New --overwrite option, replaces need to for user to use
+    git merge -s ours.  Closes:#838718.
+  * When generating quilt patches from git commits, make patches that
+    look quite like git-format-patch output (rather than strange things
+    based on an obselete interpretation of DEP-3).
+  * When generating quilt patches from git commits, honour (and strip)
+    any Gbp-Pq headers (that we understand).
+  * Several dgit-generated commits now have slightly better annotations
+    from dgit about what it was doing.
+  * Make --quilt=gbp the default for dgit gbp-build.
+  * New tag format (for dgit view) archive/debian/VERSION.
 
   Infrastructure:
   * Better error handling in dgit-repos-policy-debian.
@@ -34,6 +50,7 @@ dgit (1.5~~) unstable; urgency=medium
 
   Documentation:
   * Document the dgit-distro.DISTRO.quilt-mode config setting.
+  * Clarify the --clean= options' documentation.  Closes:#800054.
 
   Bugfixes:
   * When cleaning up after failed clone, stat the to-be-cleaned-up
@@ -49,6 +66,20 @@ dgit (1.5~~) unstable; urgency=medium
   * When synthesing a commit from a .dsc from the archive, stop
     internal git reset from printing a confusing message about HEAD.
   * Turn off git gc in the private working areas.
+  * Do not fail to do some important quilt processing in some
+    --quilt modes.
+  * Fix two calls to chdir without proper error checking.
+  * Fix a couple of bugs in error reporting.
+  * Fix up .orig detection to be less trustful of (ambiguous) filenames.
+  * Fix up .orig detection to correctly allow exactly the right
+    .orig-comp components accorging to dpkg-source(1).
+  * Fix up .orig detection to handle .asc's (and other signatures)
+    of .orig components the same way as their tarballs.
+  * Tidy up refs/dgit-fetch/ after dgit fetch (if successful).
+  * Fix handling of in-archive copies.
+  * Don't break if user has push.followTags=true.  Closes:#827878.
+  * Arrange for the special dgit remote to be skipped by git fetch --all
+    etc.  Closes:#827892.
 
   Test suite:
   * When sbuild fails, do not crash due to sed not finding the log