chiark / gitweb /
remove source-depends rule, not needed....
[developers-reference.git] / debian / rules
index 693197cf177cdabe2fdfc0219061b43d59b1403f..f58cb8a51b054e8c800992e14edcc306008fffd3 100755 (executable)
@@ -25,9 +25,22 @@ compress     := gzip -9f
 DEB_VERSION    := $(shell LC_ALL=C dpkg-parsechangelog | grep ^Version: | sed 's/^Version: *//')
 DATE           := $(shell date +"%Y-%m-%d")
 
-
-build:
+# source depends -- check if these packages are installed
+SRC_DEPENDS    := debiandoc-sgml lout psutils
+
+.PHONY: source-depends
+source-depends:
+       @set -e                                                         ;\
+       for dep in $(SRC_DEPENDS); do                                   \
+           echo "checking if package \`$$dep' is installed..."         ;\
+           dpkg --get-selections | grep "$$dep\W\+install" ||  \
+               exit 1                                                  ;\
+       done
+       @echo "all source-depends seem to be installed, good"
+
+build: developers-reference.sgml
        $(checkdir)
+       #./debian/rules source-depends
        rm -f version.ent
        echo "<!entity version \"$(DEB_VERSION)\">" >> version.ent
        echo "<!entity date    \"$(DATE)\">"        >> version.ent