chiark / gitweb /
changelog: document changes since 0.6.0
[secnet.git] / debian / changelog
index 7ed666438d4f30c89d86331400bb8a8c4ca90f0f..623e1774e4dbe9a55382b7a12b6c09b853f3858f 100644 (file)
@@ -1,25 +1,55 @@
-secnet (0.6.0~) unstable; urgency=medium
+secnet (0.6.1~) unstable; urgency=medium
+
+  Logging bugfixes:
+  * Fix completely broken startup logging.  Config errors would not
+    be repoorted other than via the exit status!  (Broken in 0.6.0.)
+  * Suppress various uninteresting messages during startup, to
+    avoid noise during successful startup.
+  * Move "starting" message earlier.
+  
+  make-secnet-sites bugfixes:
+  * Fix error handling if caller is in wrong group.
+  * Fix regressions in handling of delegated sites file fragments
+    (especially wrt the optional group parameter to `location').
+    Broken since security fixes in 0.5.0.
+
+  Fixes to example config file:
+  * Use new name-prefixed format for map(site...) runes.  Old runes
+    were desupported by make-secnet-sites security fix (in 0.5.0).
+  * Fix "transform" syntax (broken since 0.3.0).
+
+  Other bugfixes and improvements:
+  * rsa: Do not crash if private key file is not accessible when
+    running --just-check-config.  (Broken since 0.6.0.)
+  * rsa: Print errno value if we fail to open key file.
+  * config parsing: When closure is of wrong type, give details.
+  * Use CLOCK_MONOTONIC for all our timing needs (but only when
+    built against an as-yet-unpublished adns feature).
+
+  Supporting changes:
+  * Tests for some of the changes.
+  * Minor internal refactorings and improvements.
+  * Merge subdirmk 1.0.
+
+ --
+
+secnet (0.6.0) unstable; urgency=medium
 
   Bugfixes:
   * mobile sites: Do not ever expire peer addresses.  In practice
     this fixes transitions between IPv6-only and IPv4-only networks.
   * make-secnet-sites: Tainted: Fix a lot of bad return values
     (which would result in assertions rather than nice error messages).
+  * Fix hash algo confusion in mixed sha1/md5 configurations (see below).
 
-  Minor incompatible changes:
+  Incompatible changes:
+  * site: Always advertise all capabilities, even in MSG1.  This is
+    incompatible with secnets earlier than 0.3.0 (September 2013), which
+    are all quite badly broken and should have been upgraded long ago.
   * Drop support for using the same loaded rsa key with multiple different
     hash algorithms (which was broken in 0.5.0).  Right now we support
     only `sha1' and `md5' so everyone should be using `sha1'.
-    Installations which specified `md5' aywhere may need config changes.
-  * site: Always advertise all capabilities, even in MSG1.
-    This is incompatible with secnets earlier than 0.3.0 (September 2013);
-    all older versions are quite broken in other ways.
-
-  secnet logging improvements:
-  * Make stderr line buffered and log to it by default.
-  * Do not log differently with --nodetach
-  * New `prefix' option to `logfile' closure
-  * Tidy and simplify some messages
+    Installations which specified `md5' anywhere may need config changes.
 
   Major new featureset (use of which is not adviseable yet):
   * New facilities for negotiating about the signing keys to use for
@@ -29,24 +59,39 @@ secnet (0.6.0~) unstable; urgency=medium
     possible but rather complex.  Further machinery is planned;
     for now, retain your existing config which should keep working.
     In summary:
-       - secnet: new `privcache' closure
-       - secnet: `key-cache' and `peer-keys' keys on site closures
-       - secnet: new file format for peer public keysets
-       - new `make-public' verb
-       - make-secnet-sites `pub', `pkg', `serial', etc. keywords
-       - make-secnet-sites --filter, --pubkeys-*, --output-version
+       - secnet: new `privcache' closure;
+       - secnet: `key-cache' and `peer-keys' keys on site closures;
+       - secnet: new file format for peer public keysets;
+       - secnet: new `make-public' config operator;
+       - make-secnet-sites `pub', `pkg', `serial', etc. keywords;
+       - make-secnet-sites --filter, --pubkeys-*, --output-version.
+
+  More minor (logging) improvements:
+  * Make stderr line buffered and log to it by default.
+  * Do not log differently with --nodetach.
+  * New `prefix' option to `logfile' closure.
+  * Tidy and simplify some messages.
 
   Supporting changes:
-  * Many substantial internal refactorings in secnet
-  * Many substantial internal refactorings in make-secnet-sites
-  * Imported subtrees for base91-c and base91-python
-  * New portablity code, etc.: osdep.[ch], fmemopen reimplementation
-  * Explicitly define oddly-rotated dh padding arrangement (write_mpbin)
+  * Many substantial internal refactorings in secnet.
+  * Many substantial internal refactorings in make-secnet-sites.
+  * make-secnet-sites option parsing totally replaced.
+  * Imported subtrees for base91-c and base91-python.
+  * New portablity code, etc.: osdep.[ch], fmemopen reimplementation.
+  * Explicitly define oddly-rotated dh padding arrangement (write_mpbin).
+
+  Build system and packaging:
+  * Do not fail to build from git when HEAD refers to a packed ref.
+  * Update to subdirmk 0.3.
+  * Many makefile fixes (esp. to clean and cdeps).
+  * configure.ac: Drop or suppress some very obsolete checks.
+  * autogen.sh: Write a comment about need for autoheader.
+  * dir-locals: Provide python-indent-offset too.
 
   Test suite bugfixes:
-  * stest: Use stderr, not tty, for logging
-  * stest/udp-preload.c: Fix error handling of sun_prep
-  * stest: Fix breakage if nproc is not installed
+  * stest: Use stderr, not tty, for logging.
+  * stest/udp-preload.c: Fix error handling of sun_prep.
+  * stest: Fix breakage if nproc is not installed.
 
   Test suite improvements:
   * New tests, including tests for new features.
@@ -58,15 +103,7 @@ secnet (0.6.0~) unstable; urgency=medium
   * stest: Better support for cwd with longish pathname.
   * stest: More flexibility, env var hooks, etc.
 
-  Build system and administrivia
-  * Do not fail to build from git when HEAD refers to a packed ref
-  * Update to subdirmk 0.3
-  * Many makefile fixes (esp. to clean and cdeps)
-  * configure.ac: Drop or suppress some very obsolete checks
-  * autogen.sh: Write a comment about need for autoheader
-  * dir-locals: Provide python-indent-offset too
-
- --
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Sun, 16 Feb 2020 12:48:13 +0000
 
 secnet (0.5.1) unstable; urgency=medium