chiark / gitweb /
do not fail if no quilt patches to pop
[topgit.git] / debian / tg2quilt.mk
index f4ca0dbf3078a36d467a2779a3d3b91ff4f0af1e..f83caa6701f95fb6b2a540c24e53ebb877b78a76 100644 (file)
@@ -122,7 +122,7 @@ else
   tg-rmdir: __TG_FILES := $(shell find $(QUILT_PATCH_DIR) -type f -a -not -path \*/series \
                                     | xargs grep -l '^tg:')
   tg-rmdir:
-       QUILT_PATCHES=$(QUILT_PATCH_DIR) quilt pop -a
+       QUILT_PATCHES=$(QUILT_PATCH_DIR) quilt pop -a 2>/dev/null || :
        @if quilt applied >/dev/null 2>&1; then \
          echo "E: there are applied quilt patches." >&2; \
          echo "E: please unapply (pop) all patches and try again." >&2; \