chiark / gitweb /
do not fail if no quilt patches to pop
[topgit.git] / debian / tg2quilt.mk
index 1a8893acfc1c42e6cb23f4818d61224d4e87c33c..f83caa6701f95fb6b2a540c24e53ebb877b78a76 100644 (file)
@@ -122,7 +122,7 @@ else
   tg-rmdir: __TG_FILES := $(shell find $(QUILT_PATCH_DIR) -type f -a -not -path \*/series \
                                     | xargs grep -l '^tg:')
   tg-rmdir:
-       QUILT_PATCHES=$(QUILT_PATCH_DIR) quilt pop -a
+       QUILT_PATCHES=$(QUILT_PATCH_DIR) quilt pop -a 2>/dev/null || :
        @if quilt applied >/dev/null 2>&1; then \
          echo "E: there are applied quilt patches." >&2; \
          echo "E: please unapply (pop) all patches and try again." >&2; \
@@ -161,7 +161,7 @@ tg-cleanexport: tg-rmdir
 
 endif
 
-.PHONY: tg-clean tg-export tg-forceclean tg-rmdir
+.PHONY: tg-clean tg-export tg-forceclean tg-rmdir tg-cleanexport
 
 # vim:ft=make:ts=8:noet
 # -*- Makefile -*-, you silly Emacs! (shamelessly stolen from quilt)