chiark
/
gitweb
/
~bjharris
/
bedstead-debian.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
08cfa89
)
Trivial "make dist" rule.
author
Ben Harris
<bjh21@bjh21.me.uk>
Tue, 26 Nov 2013 23:29:02 +0000
(23:29 +0000)
committer
Ben Harris
<bjh21@bjh21.me.uk>
Tue, 26 Nov 2013 23:29:02 +0000
(23:29 +0000)
Makefile
patch
|
blob
|
history
diff --git
a/Makefile
b/Makefile
index 1e596cfd3b8414924dc7ff99b94463e7b5524b1f..bb481c78f94615d4d9c22fcea460ccb29eeba88c 100644
(file)
--- a/
Makefile
+++ b/
Makefile
@@
-19,3
+19,16
@@
bedstead-%-df.png: df.ps bedstead.pfa
.PHONY: clean
clean:
rm -f bedstead *.sfd *.otf *.bdf *.pfa *.png
+
+DISTFILES = bedstead.c Makefile \
+ bedstead.sfd bedstead.otf bedstead.pfa bedstead.afm \
+ bedstead-10.bdf bedstead-20.bdf \
+ bedstead-10-df.png bedstead-20-df.png
+
+.PHONY: dist
+
+dist: $(DISTFILES)
+ mkdir bedstead-dist
+ ln $(DISTFILES) bedstead-dist
+ zip -r bedstead.zip bedstead-dist
+ rm -r bedstead-dist