chiark / gitweb /
Make a package of X bitmap fonts
authorBen Harris <bjh21@bjh21.me.uk>
Fri, 29 Nov 2024 09:36:17 +0000 (09:36 +0000)
committerBen Harris <bjh21@bjh21.me.uk>
Tue, 3 Dec 2024 16:16:57 +0000 (16:16 +0000)
debian/clean
debian/control
debian/rules
debian/xfonts-bedstead.alias [new file with mode: 0644]
debian/xfonts-bedstead.install [new file with mode: 0644]

index 768079b7afd4076d36c06c1cc8aea6e14e18c1a0..65abc89f91c9ac924f31b1f69d508cfe0008e07a 100644 (file)
@@ -1,2 +1,4 @@
+*.pcf
+*.pcf.gz
 *.psf
 *.psf.gz
index 88da6aa5a01479545ede97e89e3b5b072dfdc275..28cc3c365f5338ed944d83894665b7346174fd23 100644 (file)
@@ -2,7 +2,8 @@ Source: bedstead
 Maintainer: Ben Harris <bjh21@bjh21.me.uk>
 Section: non-free/fonts
 Priority: optional
-Build-Depends: fonttools, ghostscript, bdf2psf, debhelper-compat (= 13)
+Build-Depends: fonttools, ghostscript, xfonts-utils, bdf2psf,
+ debhelper-compat (= 13)
 Standards-Version: 4.7.0
 Homepage: https://bjh21.me.uk/bedstead/
 Rules-Requires-Root: no
@@ -29,6 +30,19 @@ Description: monospaced fonts inspired by SAA5050 character generator
  weights (medium and bold) and six widths (ultra condensed, extra
  condensed, condensed, semi condensed, normal, and extended).
 
+Package: xfonts-bedstead
+Architecture: all
+Multi-Arch: foreign
+Depends: ${misc:Depends}
+Description: console fonts inspired by SAA5050 character generator
+ Bedstead is a family of angular monospaced fonts based on the
+ characters produced by the Mullard SAA5050 series of Teletext
+ Character Generators as used in the BBC Microcomputer.
+ .
+ This packages contains bitmap fonts suitable for use with the
+ X Window System.  It includes 10-pixel and 20-pixel medium fonts
+ and a 20-pixel bold font.
+
 Package: consolefonts-bedstead
 Architecture: all
 Multi-Arch: foreign
index 9bb1e0b28d601ccadbb890fbb9cd3eabd12e0763..3b82fff9314e8e40041ffea1acba0eb7387512ac 100755 (executable)
@@ -5,6 +5,18 @@
 override_dh_compress:
        dh_compress -X.pdf
 
+### Build X fonts from upstream BDFs.
+
+PCFGZS = bedstead-10.pcf.gz bedstead-20.pcf.gz bedstead-bold-20.pcf.gz
+
+%.pcf: %.bdf
+       bdftopcf -t -o $@ $<
+
+%.pcf.gz: %.pcf
+       gzip -9nk $<
+
+### Build console fonts from upstream BDFs.
+
 # We restrict ourselves to codesets that are reasonably well-covered
 # by Bedstead.
 
@@ -44,5 +56,6 @@ symbols = $(B2PDIR)/ascii.set+$(B2PDIR)/linux.set+$(fontset)+:$(B2PDIR)/useful.s
 %.psf.gz: %.psf
        gzip -9nk $<
 
-execute_after_dh_auto_build: $(PSFGZS)
+
+execute_after_dh_auto_build: $(PCFGZS) $(PSFGZS)
        true
diff --git a/debian/xfonts-bedstead.alias b/debian/xfonts-bedstead.alias
new file mode 100644 (file)
index 0000000..9d1452b
--- /dev/null
@@ -0,0 +1,3 @@
+bedstead-10      -bjh21-Bedstead-Medium-R-Normal--*-10-*-*-C-*-ISO10646-1
+bedstead-20      -bjh21-Bedstead-Medium-R-Normal--*-20-*-*-C-*-ISO10646-1
+bedstead-bold-20 -bjh21-Bedstead-Bold-R-Normal--*-20-*-*-C-*-ISO10646-1
diff --git a/debian/xfonts-bedstead.install b/debian/xfonts-bedstead.install
new file mode 100644 (file)
index 0000000..4ff1435
--- /dev/null
@@ -0,0 +1,2 @@
+*.pcf.gz /usr/share/fonts/X11/misc
+debian/xfonts-bedstead.alias /etc/X11/fonts/misc