chiark / gitweb /
Remove everything relating to PFA and AFM files.
authorBen Harris <bjh21@bjh21.me.uk>
Mon, 9 Apr 2018 21:14:10 +0000 (22:14 +0100)
committerBen Harris <bjh21@bjh21.me.uk>
Mon, 9 Apr 2018 21:14:10 +0000 (22:14 +0100)
Nothing in the build system uses them now, and I'd already stopped
distributing them.

Makefile

index c36d6c751a2f4134e13d94af86ad889084954f8a..67cd2fdfa484003e904a11e812185c30a1795a70 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -3,8 +3,6 @@ FONTBASES = bedstead bedstead-extended bedstead-semicondensed \
 
 SFDFILES = $(addsuffix .sfd, $(FONTBASES))
 OTFFILES = $(addsuffix .otf, $(FONTBASES))
-PFAFILES = $(addsuffix .pfa, $(FONTBASES))
-AFMFILES = $(addsuffix .afm, $(FONTBASES))
 
 DISTFILES = bedstead.c Makefile COPYING \
        $(OTFFILES) \
@@ -59,9 +57,6 @@ bedstead-chiseltip.sfd: strokefont.py bedstead-oc.sfd
            -c 'Open($$1); Generate($$2)' \
            $< $*.otf
 
-%.pfa %.afm: %.sfd
-       fontforge -lang=ff -c 'Open($$1); Generate($$2)' $< $*.pfa
-
 %.png: %.ps $(OTFFILES)
        gs -P -q -dSAFER -sDEVICE=pnggray -dTextAlphaBits=4 -o $@ $<
 
@@ -76,7 +71,7 @@ bedstead-complement.pdf: bedstead-complement.ps bedstead.otf
 
 .PHONY: clean
 clean:
-       rm -f bedstead *.sfd *.otf *.bdf *.pfa *.afm *.png *.pdf complement.ps
+       rm -f bedstead *.sfd *.otf *.bdf *.png *.pdf complement.ps
 
 .PHONY: dist