chiark / gitweb /
Switch to using text for the Web page title
authorBen Harris <bjh21@bjh21.me.uk>
Sun, 22 Mar 2020 12:59:51 +0000 (12:59 +0000)
committerBen Harris <bjh21@bjh21.me.uk>
Sun, 22 Mar 2020 12:59:51 +0000 (12:59 +0000)
A typical Web browser support Web Fonts these days, so there's no need
to use an image for the purpose.  The other images remain for now since
they're not really representing text.

Makefile
bedstead.css
index.xhtml
title.ps [deleted file]

index 879a6a50598ebb32a9bb0a404a071ff950b5b77e..9cf97039c0bf9f2e6075af9932d4cec06b0468ee 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -11,7 +11,7 @@ DISTFILES = bedstead.c Makefile COPYING NEWS \
        bedstead-complement.pdf
 
 all: $(DISTFILES) \
-     sample.png title.png extended.png
+     sample.png extended.png
 
 .PHONY: experimental
 experimental: bedstead-chiseltip.otf bedstead-plotter-thin.otf \
index c7a34079bc012f7926e1c2cfc2c85ed9bca3f443..022f6ba8b6ead0860eedb862433925d6bf68142b 100644 (file)
@@ -23,6 +23,13 @@ pre {
     line-height: 1em;
 }
 
+h1 {
+    font-size: 5em;
+    font-weight: inherit;
+    margin-top: 0;
+    margin-bottom: -0.2em;
+}
+
 h2 {
     font-size: 2em;
     font-stretch: ultra-condensed;
index db0cf0374e4f349037794a6adf4deb26703dbab7..4855e808af0f2e97e9d570216b23d6f713e17f5b 100644 (file)
@@ -9,7 +9,7 @@
     <link rel="stylesheet" href="bedstead.css" type="text/css" />
   </head>
   <body>
-    <h1><img alt="Bedstead" src="title.png"/></h1>
+    <h1>Bedstead</h1>
     <p>Bedstead is a family of outline fonts based on the characters
       produced by the
       Mullard SAA5050 series of Teletext Character Generators.  The
diff --git a/title.ps b/title.ps
deleted file mode 100644 (file)
index b8eea45..0000000
--- a/title.ps
+++ /dev/null
@@ -1,8 +0,0 @@
-<< /HWResolution [ 72 72 ] /PageSize [ 470 90 ] >> setpagedevice
-/Bedstead findfont 100 scalefont setfont
-0 10 moveto
-/s { show } def
-/k { -10 0 rmoveto } def
-% Manually apply the 'palt' OTF feature to improve the spacing
-(Beds) s k (t) s k (ead) s
-showpage