chiark
/
gitweb
/
~bjharris
/
bedstead-debian.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
5a186ed
)
Use GNU Make pattern rules to get correct requirements for sample images.
author
Ben Harris
<bjh21@bjh21.me.uk>
Sat, 23 Nov 2013 19:03:57 +0000
(19:03 +0000)
committer
Ben Harris
<bjh21@bjh21.me.uk>
Sat, 23 Nov 2013 19:03:57 +0000
(19:03 +0000)
Makefile
patch
|
blob
|
history
diff --git
a/Makefile
b/Makefile
index 953ccc301638f423095b06239bd1418b5d3e200d..f99e72ea327e74c318a4c8b1aad20be7341e4921 100644
(file)
--- a/
Makefile
+++ b/
Makefile
@@
-3,15
+3,13
@@
all: bedstead.otf sample.png title.png
bedstead.sfd: bedstead
./bedstead > bedstead.sfd
-.SUFFIXES: .ps .png .sfd .otf .pfa
-
-.sfd.otf:
+%.otf: %.sfd
fontforge -lang=ff -c 'Open($$1); BitmapsAvail([10, 20]); Generate($$2, "bdf")' $< $@
-.sfd.pfa:
+%.pfa: %.sfd
fontforge -lang=ff -c 'Open($$1); Generate($$2)' $< $@
-
.ps.png:
bedstead.pfa
+
%.png: %.ps
bedstead.pfa
gs -dSAFER -sDEVICE=pnggray -dTextAlphaBits=4 \
-o $@ bedstead.pfa $<