chiark / gitweb /
Make any rule that uses Ghostscript depend on the Fontmap.
authorBen Harris <bjh21@bjh21.me.uk>
Mon, 9 Apr 2018 21:27:24 +0000 (22:27 +0100)
committerBen Harris <bjh21@bjh21.me.uk>
Mon, 9 Apr 2018 21:27:24 +0000 (22:27 +0100)
Makefile

index 9a870397a046d0f8b30f30f3e179cea593050d29..c15b41e0b5c8e61d6e9abda8d75c4ee7916c799e 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -57,16 +57,16 @@ bedstead-chiseltip.sfd: strokefont.py bedstead-oc.sfd
            -c 'Open($$1); Generate($$2)' \
            $< $*.otf
 
-%.png: %.ps $(OTFFILES)
+%.png: %.ps $(OTFFILES) Fontmap
        gs -P -q -dSAFER -sDEVICE=pnggray -dTextAlphaBits=4 -o $@ $<
 
-bedstead-%-df.png: df.ps bedstead.otf
+bedstead-%-df.png: df.ps bedstead.otf Fontmap
        gs -P -q -dSAFER -dsize=$* -sDEVICE=png16m -o $@ $<
 
 bedstead-complement.ps: bedstead
        ./bedstead --complement > bedstead-complement.ps
 
-bedstead-complement.pdf: bedstead-complement.ps bedstead.otf
+bedstead-complement.pdf: bedstead-complement.ps bedstead.otf Fontmap
        ps2pdf -P $< $@
 
 .PHONY: clean